racl101 + error   190

Nginx: 413 - Request Entity Too Large Error and Solution - nixCraft
Encountered this with huge uploads even though I changed the PHP post and upload max size settings. It turned out, I had to also set client_max_body_size in my nginx virtual host file.
cyberciti  blog  tutorial  howto  fix  troubleshoot  linux  http  error  code  413  request  entity  too  large  file  upload  max  post  settings  config  virtual  host  virtualhost  client_max_body_size  setting  example  guide  reference 
8 weeks ago by racl101
Solving the Error: route [login] not defined in laravel 5.5
This is important if building an api with Passport on Laravel5.

Also, if using a roles and permissions library such as the Spatie Laravel Permissions library consider doing something like this:

public function render($request, Exception $exception)
if($exception instanceof \Spatie\Permission\Exceptions\UnauthorizedException && $request->expectsJson()) {
return response()->json([
'status' => $exception->getStatusCode(),
'success' => false,
'error' => [
'code' => null,
'message' => 'User does not have the right permissions'
], $exception->getStatusCode());

return parent::render($request, $exception);
medium  blog  howto  example  fix  troubleshoot  route  not  defined  error  response  json  javascript  exception  handler  401 
february 2019 by racl101
javascript - A Parser-blocking, cross-origin script is invoked via document.write - how to circumvent it? - Stack Overflow
How to deal with the: "A Parser-blocking, cross-origin script, http://example.org/script.js, is invoked via document.write. This may be blocked by the browser if the device has poor network connectivity." from Google Chrome browser.
stackoverflow  howto  troubleshoot  google  chrome  error  parser  blocking  cross  origin  script  javascript  example  guide  reference  async 
june 2018 by racl101
ajv@^6.0.0 is missing · Issue #9691 · angular/angular-cli
I fixed this for myself by installing: npm install ajv@^6.0.0 from within the project directory. Not sure if this is the best way of dealing with the issue.
github  forum  angular  angular-cli  npm  install  howto  troubleshoot  issue  error  ajv  dependency  project  guide  reference 
april 2018 by racl101
Error: Cannot find module 'internal/util/types' · Issue #1124 · remy/nodemon
I was only able to fix this for myself by installing NodeJS / NPM with nvm and by installing the LTS Boron NodeJS version (v6.14.1) and npm version (v3.10.10) as of April 27, 2018.

I encountered this error when trying to run the DCIDA Web app Grunt task.
github  nodejs  npm  internal  util  types  error  howto  troubleshoot  fix  dependency  grunt  guide  reference 
april 2018 by racl101
MySQLdb User's Guide
I don't get it, but I guess you're supposed to use %s as a placeholder even for integers (so not %d) in a query string that is used in a cursor.execute() statement. I tried it with pymysql. I'm not sure why, but it worked.

This is the explanation: In this example, max_price=5 Why, then, use %s in the string? Because MySQLdb will convert it to a SQL literal value, which is the string '5'. When it's finished, the query will actually say, "...WHERE price < 5".
mysql-python  howto  troubleshoot  cursor  mysql  pymysql  query  python  python2.7  string  format  number  error  fix  guide  reference  examples 
april 2018 by racl101
mysql - MySQLdb Python insert %d and %s - Stack Overflow
I don't get it, but I guess you're supposed to use %s as a placeholder even for integers (so not %d) in a query string that is used in a cursor.execute() statement. I tried it with pymysql. I'm not sure why, but it worked.
stackoverflow  howto  troubleshoot  cursor  mysql  pymysql  query  python  python2.7  string  format  number  error  fix  guide  reference 
april 2018 by racl101
insertion - Python MySQLdb issues (TypeError: %d format: a number is required, not str) - Stack Overflow
I don't get it, but I guess you're supposed to use %s as a placeholder even for integers (so not %d) in a query string that is used in a cursor.execute() statement. I tried it with pymysql. I'm not sure why, but it worked.
stackoverflow  howto  troubleshoot  cursor  mysql  pymysql  query  python  python2.7  string  format  number  error  fix  guide  reference 
april 2018 by racl101
Error: duplicate listen options for [::]:443 · Issue #5550 · certbot/certbot
This happened to me when I tried to create an SSL certificate for two virtual hosted sites that share the same top level domain but have different subdomains and their www versions.

E.g. site1.myawesomesite.com and site2.myawesomesite.com (and their www versions www.site1.myawesomesite.com and www.site2.myawesomesite.com )


change listen [::]:443 ssl ipv6only=on; to listen [::]:443;
github  forum  letsencrypt  ssl  certificate  ubuntu  ubuntu16.04  howto  troubleshoot  fix  duplicate  listen  options  error  virtualhost  example  guide  reference 
march 2018 by racl101
I 'm getting error "Class 'PredisClient' not found" in Laravel 5.2 - Stack Overflow
Had this issue on Laravel 5.5 when I wanted to set Supervisord to do some queue work on a Beanstalkd Queue. Fixed issue by simply installing predis/predis package.
stackoverflow  howto  troubleshoot  laravel  laravel5  laravel5.5  error  message  supervisord  beanstalkd  queue  redis  fix  guide  reference 
january 2018 by racl101
Errors & Logging - Lumen - PHP Micro-Framework By Laravel
If you have problems with errors not being shown on the browser or not being logged to the storage/lumen.log file then chances are the permissions for storage/lumen.log are the issue. Give it read and write permissions so that the www-data user group can write to it too.
lumen  lumen5.5  error  logging  guide  reference  documentation  tutorial 
january 2018 by racl101
Getting Nginx fpm.sock error | DigitalOcean
If you encounter this error, perhaps the error is with your pool settings. Namely, the max_children and the like type of settings.
digitalocean  forum  troubleshoot  fpm  sock  missing  file  error  php-fpm  pool  nginx  php 
december 2017 by racl101
Prevent nginx 504 Gateway timeout using PHP set_time_limit() - Stack Overflow
Really helpful example showing how to set max execution time on an nginx server running php fpm. Works for PHP 7, Nginx and PHP FPM on Ubuntu 16.04
stackoverflow  howto  example  guide  reference  increase  max  execution  time  limit  nginx  ubuntu  ubuntu16.04  php  php7  php-fpm  virtualhost  prevent  504  timeout  error 
september 2017 by racl101
« earlier      
per page:    204080120160

related tags

$_FILE  @  access  ACCESS_log  ACRA  adapter  address  add_settings_error  ajax  ajv  alamofire  alternative  Amazon  android  angular  angular-cli  Angularjs  ansible  ant  apache  apache2  api  app  apple  applescript  argument  Array  askubuntu  assig  assign  async  authority  automator  available  avoid  away  aws  backup  backupbuddy  bash  be  beanstalkd  between  bitwise  blade  blocking  blog  Bootstrap  brew  browser  Bucket  bug  build  bundler  c  cacert.pem  caching  call  callback  can't  cannot  catch  cell  cert  certificate  cgpoint  cgsize  Child  chrome  chunking  ci  class  cli  clicks  client_max_body_size  closure  cloudsites  cocoapod  code  codeigniter  Codekit  codes  codesniffer  codinghorror  column  command  commandline  compilation  compiler  component  composer  computer  conf  config  configuration  connection  console  constant  constants  constraint  constructor  consumed  container  context  control  controller  Cors  count  coverage  CRAsh  create  Createdb  crect  cross  CSS  curl  cursor  custom  customposttypes  cyberciti  data  database  datetime  db:migrate  dba.stackexchange  dbal  Dead  debug  debugging  default  defined  definition  delimiter  denied  dependencies  dependency  deprecated  design  dev  Developer  development  difference  digitalocean  directive  directory  display  displaying  docker  docker-compose  doctrine  documentation  driver  drupal  dsl  duplicate  dylib  dynamiclibrary  edit  editor  ee2  EISDIR  elasticsearch  element  eloquent  else  email  end  entity  entry  enum  environment  error  errorcodes  errorhandling  errors  error_codes  error_log  etag  example  examples  exception  exceptions  execution  EXISTS  exit  expired  explanation  expressionengine  extending  extension  extract  fail  failure  fallback  fastcgi  fatal  features  fetch  file  files  filter  finder  Fineuploader  firefox  fix  flags  flow  FollowSymLinks  Forbidden  foreign  form  format  forum  found  fpm  free  from  front  front-end  fullstory  fun  Function  functions  funny  gateway  gem  gems  getaddresses  getmessage  getting  github  global  gone  google  gotcha  grant  grep  grunt  guide  guzzle  guzzlehttp  hack  handle  handler  handles  handling  header  help  Homebrew  host  howto  htaccess  htop  http  humor  ie  if  ignore  image  increase  index  initializer  install  installation  installed  integrity  internal  interpreter  invalid  invariant  ios  iphone  issue  issues  iterator  java  javascript  jdk  jenkins  jenkins-cli.jar  jquery  jre  js  json  key  keychain  knowledgebase  laracasts  laravel  laravel4  laravel4.2  laravel5  Laravel5.0  Laravel5.1  laravel5.2  laravel5.5  large  less  letsencrypt  library  limit  Link  linker  linux  list  listen  local  localhost  localstorage  location  log  logging  login  lumen  lumen5.5  machine  macos  macosx  mail  manual  manually  many  maps  max  maximum  max_input_vars  mediatemple  medium  message  messages  method  migrations  mismatch  missing  mistakes  mix  mode  model  module  monitoring  mozilla  mustache  mysql  mysql-python  mysql5.7  name  named  net-scp  netscp  network  newline  nginx  nil  nixcraft  no  node  nodejs  non-compound  not  npm  number  old  onLy  open  openssl  operand  operations  operator  optimization  option  optional  options  origin  orm  output  outputting  overrun  ownership  package  package.json  packages  page  pagodabox  pagodaboxv2  parameter  parameters  parent  parentheses  parser  Passenger  passport  password  path  paypal  pdo  pem  per  permalink  permission  permissions  permitted  pg  php  php-fpm  php5  php5.3  php7  php7.0  php7.2  phpconsole  phpcs  phpini  phpize  phpunit  Phusion  PHusion  pip  playbook  plugin  pool  port  post  postgres  postgresql  prevent  print  process  processes  programming  project  promises  protection  provisioning  pyenv  pymysql  python  python2.7  python3  query  queue  Rackspace  rackspacecloud  Rage  rails  rake  reached  reactjs  recover  redis  reference  refused  release  render  report  reporting  request  requested  resolve  resources  response  responsecodes  responses  return  rewrite  role  rollbar  root  ror  route  rspec  rsync  ruby  rubyonrails  run  runtime  S3  safari  same  Sass  save  schema  Scp  script  scripting  security  seeder  self  server  Service  set  setting  settings  shell  signed  Silence  sip  site  smashingmag  sniff  sniffer  sock  sqlalchemy  sqlite  sqlite3  ssh  ssl  stack  stackexchange  stackoverflow  statement  status  stdlib  steps  Storage  string  style  subject  success  superuser  supervisord  support  swift  swift3  swift4  switch  syntax  sysadmin  system  table  tech  template  testing  THen  this  throw  time  timeout  timestamp  tinymce  tips  token  tokenmismatchexception  tolearn  too  tool  tools  tools.jar  top  toread  totry  tounderstand  traffic  trailing  trigger  troubleshoot  troubleshooting  troubleshot  truncated  try  turnon  tutorial  type  types  ubuntu  ubuntu14.04  ubuntu16.04  uglifier  uikit  uitableview  uitableviewcell  ulimit  unary  Unauthorized  undefined  unexpected  uninstall  unique  unix  unixcraft  unsigned  unwrapping  unzip  update  upload  url  use  util  v3  vagrant  validate  validation  value  vendor  veriable  version3  views  Violation  virtual  virtualhost  vue  vue-template-compiler  vue2  vuejs  w3schools  wamp  warning  web  webdev  webkit  webmaster.stackexchange  webpack  website  whitespace  whoops  wiki  windows  wordpress  worker_rlimit_nofile  workspace  wrap  Xcache  xcode  xcode9  xcode9.2  xdebug  Xmal  yaml  zip  zoho  zohocrm 

Copy this bookmark: