ezequiel + issue   770

shell - How can I find the path to a script being sourced in dash? - Stack Overflow
Q: I am trying to have a sourced shell script determine its own location, and I have found that this is a difficult task for dash.

In bash, sh, and csh, I can use: $_.

In fish, I can use (status -f).

In dash, I have had no luck... [...]
2015  forumthread  stackexchange  scripting  shell  dash  bash  posix  unix  tips  example  issue  workaround 
11 days ago by ezequiel
xubuntu - Why does light-locker keep the screen black after unlock? - Ask Ubuntu
Q: A Xubuntu 16.04 fully patched machine with a freshly created user wont let me unlock after using light-locker to lock my screen (regardless if lock was activated manually or via timeout). The screen remains black (but powered) on correct password entry

Killing light-locker from tty1 will reveal the desktop then (and consequently prevents further locking). [...]

A: TL;DR: light-locker keeps the screen black if systemd cannot read /proc

* light-locker depends on dbus providing IPC.
* dbus depends on systemd-logind providing session information.
* systemd-logind depends on /proc providing process information. [...]
2017  forumthread  stackexchange  internals  desktop  xfce  xubuntu  issue  workaround  tips  example  cli  sysadmin  security  hardwaresupport  systemd  dbus  ui 
12 days ago by ezequiel
xfce - Xubuntu: black screen after lock screen (light-locker, lightdm, logind, xfce4-power-manager) - Ask Ubuntu
Q: [...] The problem is that when my laptop goes into lock screen (or maybe suspend but I always disable that in power management options so it shouldn't), then it is quite common that I am not able to login back to it. Screen stays black after opening lid and pressing a button. [...]

A: The issue is due to lightlocker and XFCE no longer playing well.

I was able to fix this issue by upgrading to XFCE 4.14 from the Xubuntu staging PPA, removing light-locker and installing xfce4-screensaver. Please note I did this from a clean install of 18.04.3, so you might need to restore any changed settings.

sudo add-apt-repository ppa:xubuntu-dev/staging
sudo apt update
sudo apt upgrade
sudo apt remove light-locker
sudo apt install xfce4-screensaver
xfce  desktop  issue  workaround  packages  cli  sysadmin  debian  ubuntu  mint  security  forumthread  stackexchange  2019  ui  tips  example 
12 days ago by ezequiel
lock goes to black screen · Issue #114 · the-cavalry/light-locker
Q: [...] Since last update, unlocking with light-locker-command --lock displays a black screen with a cursor, then cursor disappear. Before it worked like a charm.
From black screen get lightm lock screen I have to switch to tty1 using Ctrl+Alt+F1 and then Ctrl + Alt + F7 [...]
desktop  software  issue  workaround  packages  arch  linux  debian  ubuntu  mint  links  forumthread  2018  github  security  ui  gui  xfce 
12 days ago by ezequiel
ndiswrapper / Wiki / Troubleshooting_HowTo
If things are not working as expected, follow instructions below.

* Make sure you have latest stable version installed; see downloads for latest versions available. Run ndiswrapper -v to check that you indeed have latest version. Follow instructions in Installation to install. You may want to Uninstall and install again if you think there is a problem with your current installation or you have older version. [...]
ndiswrapper  issue  workaround  tips  wikientry  linux  driver  drivers  sysadmin  wifi  networking  hardwaresupport  links 
12 days ago by ezequiel
Clients in same WLAN can't reach each other - Installing and Using OpenWrt / Network and Wireless Configuration - OpenWrt Forum
Q: Ethernet switch + 2.4G Wifi + 5G Wifi is bridged into one interface and firewall zone (lan).
I updated to LEDE 17.01.0 (stable) and got following problem:
Clients connected to the same Wifi SSID can not communicate with each other (same interface/firewall zone)
PING OPO.lan (192.168.0.17) 56(84) bytes of data. From MJ.lan (192.168.0.58) icmp_seq=1 Destination Host Unreachable ...
I can still reach it from Ethernet or from the other WLAN (5G -> 2.4G and vice versa) but not when both are connected to the same... It works fine if i create 2 different SSIDs on an adapter and put a client in each one.
Multiple clients connected through ethernet can also reach all others.
forumthread  openwrt  wifi  networking  firewall  configuration  issue  workaround  links  router  sysadmin  tips 
12 days ago by ezequiel
ssh - How to prevent ecryptfs from umounting home if tmux is still running? - Ask Ubuntu
Q: [...] So is there a way to prevent ecryptfs from umounting my home if there is still a (detached) tmux session running?
I know that i could just disable the encryption, but i would rather like to keep it and solve the problem someway else.
2013  forumthread  stackexchange  linux  ecryptfs  issue  workaround  tips  cli  scripting  sysadmin  filesystem  security  example 
18 days ago by ezequiel
Is there any support with a NetGear WNA3100 USB Adapter in Ubuntu 12.10? - Ask Ubuntu
Q: Has there been any changes or updates or additions to Ubuntu 12.10's to pick up a NetGear WNA3100 USB Adapter? Or software updates? Or what can I do to get it to work in the latest Ubuntu 12.10? [...]
ubuntu.precise  forumthread  2012  hardwaresupport  drivers  ndiswrapper  issue  links  usb  wifi 
18 days ago by ezequiel
linux - How to blacklist a correct bad RAM sector according to MemTest86+ error indication? - Unix & Linux Stack Exchange
Q: MemTest86+ (the version included with Ubuntu 13.04) says

Failing address: 002f796c48 - 759.5 MB

What should I specify in the memmap kernel parameter to bypass this area? [...]
memory  issue  workaround  booting  grub  kernel  kernelpatches  forumthread  stackexchange  2013  hardwaresupport  configuration  sysadmin  tips  links  x86  amd64 
19 days ago by ezequiel
#870126 - ecryptfs-mount-private: mount: No such file or directory - Debian Bug report logs
Q: I have setup the standard home ~/Private directory. It looks like it is confused about which key to use.

For the last few months or so, I get this (key IDs changed but consistent in report):

$ ecryptfs-mount-private

[...]

A: [...]

1. The problem is the user keyring not being linked
to the session keyring. keyctl link @u @s is a much easier workaround. [...]
2017  issue  workaround  ecryptfs  encryption  forumthread  cli  example  configuration  pam  filesystem  debian  ubuntu  security  tips 
23 days ago by ezequiel
encryption - SSH remote user need to be logged in? - Ask Ubuntu
Q: I'm trying to set up an SSH server. I put my public key in the authorized_keys file, made sure the permissions were correct, etc.

When I restart the server (really just Ubuntu 12.04 desktop) and I ssh to it without first logging in on the server, I am asked for a password. If, however, I log into the server, I can ssh without being asked for a password. [...]

A: The problem usually arises if your home directory is encrypted. The usual solution is to put your keys in a directory other than your home directory, and point your sshd_config file to it.

For example:

1. Move your authorized_keys file on the server from /home/buck/.ssh/authorized_keys to something like /etc/ssh/keys/buck/authorized_keys [...]
2012  forumthread  stackexchange  ecryptfs  encryption  ubuntu  debian  security  sysadmin  filesystem  issue  workaround  tips  example  configuration  ssh  remote 
23 days ago by ezequiel
encryption - Will changing password re-encrypt my home directory? - Ask Ubuntu
Q: I need to change my user password. Do I need to take any extra steps for my encrypted home directory to become inaccessible with my old password and only accessible with my new password?

A: There is no need to re-encrypt your home directory, and no further steps need to be taken.

Your home directory is not directly encrypted with your password. Instead, the passphrase used to encrypt the home directory is itself encrypted with your password.

When you change your password, the home directory passphrase is re-encrypted with your new password, so you should have continued access to your files with the new password. [...]
2011  forumthread  stackexchange  ecryptfs  encryption  ubuntu  debian  ubuntu.lucid  security  cli  sysadmin  filesystem  issue  workaround  tips  example 
23 days ago by ezequiel
linux mint - mount: No such file or directory with encrypted recovery - Unix & Linux Stack Exchange
Q: [...] Nothing I’ve tried seems to work and I don’t have the original mounting seed. I’ve also tried sudo ecryptfs-recover-private but my system then just says No such file or directory:

frankenmint@honeybadger /home $ sudo ecryptfs-recover-private
INFO: Searching for encrypted private directories (this might take a while)...
INFO: Found [/home/.ecryptfs/frankenmint/.Private].
Try to recover this directory? [Y/n]: y
INFO: Found your wrapped-passphrase
Do you know your LOGIN passphrase? [Y/n] y
INFO: Enter your LOGIN passphrase...
Passphrase:
Inserted auth tok with sig [979c6cdf80d2e44d] into the user session keyring
mount: No such file or directory
ERROR: Failed to mount private data at [/tmp/ecryptfs.Hy3BV96c].

[...]

A: I found that running sudo bash and then running ecryptfs-recover-private as root (rather than via sudo) worked. Not sure why it should be any different.

Edit:
TL;DR:

# ecryptfs-unwrap-passphrase /mnt/crypt/.ecryptfs/user/.ecryptfs/wrapped- passphrase - | ecryptfs-add-passphrase --fnek -
< Type your login password here >
Inserted auth tok with sig [aaaaaaaaaaaaaaaa] into the user session keyring
Inserted auth tok with sig [bbbbbbbbbbbbbbbb] into the user session keyring

You will not see a prompt and must type your login password, blind, into the above command. [...]
2016  forumthread  stackexchange  cli  sysadmin  encryption  filesystem  ubuntu  debian  mint  tips  issue  workaround  example  guide  linux  security  mount  ubuntu.xenial  ubuntu.trusty  ubuntu.bionic  ecryptfs 
24 days ago by ezequiel
CWSDPMI - Free DPMI provider for DOS
The CWSDPMI r7 release provides high performance access up to 4GB of physical memory using 4MB pages. You can download the r7 binary distribution or source distribution. View the r7 documentation or how to customize documentation. View the known problems with r7. The older r5 binary distribution is also available.

CWSDPMI was written to provide DPMI services for V2 of DJGPP. It does not support 16-bit DPMI applications, or DPMI applications requiring a built in extender. It does support virtual memory and hardware interrupt reflection from real mode to protected mode. DJGPP V1.1x and RSX applications will also run using this server, which can be used to provide enhanced control over hardware interrupts. Some DPMI 1.0 extensions (0x401, 0x506, 0x507, 0x508) have been implemented.
dosbox  dpmi  software  opensource  issue  workaround  memory  gaming  djgpp  dosemu  dos 
25 days ago by ezequiel
windows - How to make "git branch" respect the "core.ignorecase" flag on Linux? - Stack Overflow
Q: [...] How to make “git branch” respect the “core.ignorecase” flag on Linux? [...]

A: [...] You can't, because the flag doesn't do what you think it does. [...]
2011  forumthread  stackexchange  git  cli  configuration  tips  example  issue  filesystem  windows  linux  unix  workaround 
26 days ago by ezequiel
Power management/Suspend and hibernate - ArchWiki
Currently there are three methods of suspending available: suspend to RAM (usually called just suspend), suspend to disk (usually known as hibernate), and hybrid suspend (sometimes aptly called suspend to both): [...]
powermanagement  arch  linux  sysadmin  configuration  kernelmodule  kernel  booting  udev  example  tips  laptop  systemd  tools  acpi  workaround  issue  webcam  cpu  wifi  harddisk  networking  links  wikientry 
29 days ago by ezequiel
Power management - ArchWiki
Power management is a feature that turns off the power or switches system's components to a low-power state when inactive.

In Arch Linux, power management consists of two main parts:

* Configuration of the Linux kernel, which interacts with the hardware.
* Kernel parameters
* Kernel modules
* udev rules

* Configuration of userspace tools, which interact with the kernel and react to its events. Many userspace tools also allow to modify kernel configuration in a "user-friendly" way. See #Userspace tools for the options.
powermanagement  arch  linux  sysadmin  configuration  kernelmodule  kernel  booting  udev  example  tips  laptop  systemd  tools  acpi  workaround  issue  webcam  audio  pulseaudio  cpu  bluetooth  wifi  harddisk  networking  cd  dvd  links  wikientry 
29 days ago by ezequiel
Ubuntu 16.04 systemd unload modules on sleep
(me: simple script to force unloading and loading Linux kernel modules on suspend/resume, using 'systemd-sleep(8)' "local scripts 'hack'")
ubuntu  ubuntu.xenial  github  script  systemd  powermanagement  kernelmodule  issue  workaround  linux  example  sysadmin  laptop  links 
29 days ago by ezequiel
WNA3100 (N300) Wireless USB Adapter Support | NETGEAR
(me: ndiswrapper has issues when dealing with the windows xp (32 bit) driver on Linux kernel >= 5.0 (mint 19.3 has 5.3.0 as of 2020.03.08))
wifi  driver  windows  windowsxp  windows7  windowsvista  windows8  windows10  hardwaresupport  networking  ndiswrapper  downloads  firmware  documentation  support  reference  manual  guide  issue  workaround  hardware 
29 days ago by ezequiel
internet - Netgear N-300/ WNA3100 USB Adapter for Ubuntu 16.04 - Ask Ubuntu
Q: I am new to Linux and Ubuntu and I am having trouble connecting to the Internet.

I have a netgear WNA3100 USB Adapter and I don't have anything in my additional drivers.

A: You can add Support for the Netgear N-300/ WNA3100 USB Adapter by installing the ndiswrapper and loading the Windows network driver. [...]

(me: ndiswrapper fails to build when using kernel-headers >= 5.0 (on i686), then (even if patched) the 32-bit WinXP driver from NetGear does not work: ndiswrapper causes an "oops" because of the "nx" cpu protection bit; then, after disabling this (see another link saved today), ndiswrapper gives yet another error. Result (so far): failed).
ndiswrapper  issue  howto  guide  tips  example  cli  sysadmin  networking  wifi  2016  ubuntu  configuration  usb  driver  drivers  windows  links  linux  kernelmodule  forumthread  stackexchange 
4 weeks ago by ezequiel
Ubuntu - Fix for Slow Wireless Internet Connection Speed after upgrading to 11.04 Natty Narwhal - HitXP
Recently Ubuntu came out with its newest version 11.04 code named Natty Narwhal, and after upgrading my earlier 10.10 version Maverick to this new Version of Ubuntu, I faced my first real issue with Ubuntu in so many years – My USB Wireless Internet Connection speed had almost come to a standstill like a slow dial up connection after upgrading Ubuntu to 11.04! The connection was n times weaker than Windows based systems running on same wireless connection. Many a times it even simply dropped Internet connections. [...]
ubuntu.natty  ubuntu  configuration  sysadmin  networking  wifi  usb  performance  powermanagement  dns  tips  issue  workaround  example  cli  scripting  linux  blogpost  2011 
4 weeks ago by ezequiel
linux - How to turn off Wireless power management permanently - Unix & Linux Stack Exchange
Q: In Linux Mint 17.3 / 18 iwconfig says the power management of my wireless card is turned on. I want to turn it off permanently or some workaround on this issue.

sudo iwconfig wlan0 power off works, until I reboot the laptop.

Also, if I randomly check iwconfig, sometimes it's on, despite I did run this command. [...]

A #1: Open this file with your favorite text editor, I use nano here:

sudo nano /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

By default there is:

[connection]
wifi.powersave = 3

Change the value to 2. Reboot for the change to take effect. [...]
2016  forumthread  stackexchange  linux  ubuntu  mint  debian  networking  software  configuration  sysadmin  powermanagement  usb  issue  workaround  cli  links  documentation  tips  example  wifi 
4 weeks ago by ezequiel
Serious HDMI Problems. What's that smell? Burning Raspberry! - Raspberry Pi Forums
Q: [...] I have just received my Neewer Black HDMI Input To VGA Adapter Converter For PC Laptop.

There was a post here: [...]

That reported it working and I have no reason to doubt that. However when I plugged mine in to my raspberry pi and VGA monitor the screen was black but lit i.e. the screen recognised a connection was present but wasn't receiving any data. A thin wisp of grey smoke appeared from the HDMI and the component labelled "D1" is looking like it has burn out. Suffice to say I very quickly removed it and all power! [...]
2012  forumthread  raspberrypi  hardware  hardwaresupport  electronics  issue  workaround  tips 
4 weeks ago by ezequiel
eLinux.org
The purpose of this wiki is to preserve and present information about the development and use of Linux in embedded systems as well as open source projects and tools for general embedded development. To use this wiki, click on one of the portal links below.
wiki  resources  embedded  linux  tips  issue  workaround  links  booting  memory  power  powermanagement  multimedia  filesystem  networking  android  drivers  development  debug  kernel  security  legal  test  raspberrypi  hacking  hardware  hardwaresupport  tools  arduino  tutorials  cpu  spec  support 
4 weeks ago by ezequiel
Tp smapi - ThinkWiki
The tp_smapi kernel module exposes some features of the ThinkPad hardware/firmware via a sysfs interface. Currently, the main implemented functionality is control of battery charging and extended battery status. The tp_smapi software package also includes an improved version of the HDAPS driver. The underlying hardware interfaces are SMAPI and direct access to the embedded controller.
battery  laptop  wikientry  kernelmodule  installation  gentoo  debian  ubuntu  mint  issue  workaround  tips  example  configuration  hardwaresupport  compatibility 
4 weeks ago by ezequiel
FS#1960 : hostapd/netifd: multicast_to_unicast/hairpin not set for dynamic vlan, ap not in isolate mode
I noticed that multicast_to_unicast and hairpin_mode are not set on the dynamically created wlan interfaces, and the wireless ap is not running in isolate mode. This is because these interfaces are created by hostapd, unlike other wlan interfaces which are created from netifd/system-linux.

The attached patch fixes this:
- it sets ap_isolate for the hostapd interface, if the interface is using dynamic vlan
- it sets multicast_to_unicast and hairpin_mode after the dynamic interface is created

I haven’t handled the case where the isolate option is not set for the wifi interface, or where multicast_to_unicast is not set on the bridge, since this requires passing additional information to hostapd, and I wasn’t sure what the preferred way to do this would be. I’d probably overload the ap_isolate option to have value 2 mean that multicast_to_unicast and hairpin_mode should be set.
wifi  networking  openwrt  issue  workaround  forumthread  configuration  2018  patches 
4 weeks ago by ezequiel
FS#714 : ARP/Broadcast does not reach other clients in the same WLAN
I have the default bridge with ethernet and WLAN in it. When i try to send data from a client to another, both connected to the same WLAN SSID, it doesn’t work (Destination unreachable).
Wireshark shows that it sends endless ARP requests to Broadcast, but the other clients in that WLAN never get it (and therefore can’t answer). The broadcast gets still delivery to every client connected through Ethernet. If i create a second WLAN SSID (even on the same adapter) and and add it to the bridge, it gets also all broadcast packets from the other WLAN...
So if i put the 2 clients in different WLAN SSIDs or ethernet they get the broadcast from each other, but not when both are connected to the same.
wifi  networking  openwrt  issue  workaround  forumthread  configuration  2017 
4 weeks ago by ezequiel
15.04 - Unable to install tp_smapi 0.41 on Thinkpad T500 - Ask Ubuntu
I have downloaded tp_smapi module for my Thinkpad T500 using the steps in ThinkWiki and ran make. it encountered no errors.

[...]

But when i tried to view the status of the battery using tlp, it shows as not loaded/installed:

root@Forge:/storage/Repository/git/tp_smapi# tlp-stat -b
--- TLP 0.7 --------------------------------------------

+++ ThinkPad Extended Battery Functions
tp-smapi = inactive (kernel module 'tp_smapi' load error)
tpacpi-bat = inactive (unsupported hardware)
[...]
2015  hardwaresupport  laptop  battery  kernelmodule  tool  linux  forumthread  stackexchange  ubuntu  issue  workaround  links  sysadmin 
5 weeks ago by ezequiel
neatsoft/rpi-edid-lock: Raspberry Pi EDID locker
This utility creates the edid.dat file and changes config.txt to fix Raspberry Pi hdmi configuration issues.

usage: rpi-edid-lock.sh [-l|-u]
-l - lock
-u - unlock
raspberrypi  hardwaresupport  tool  cli  booting  configuration  sysadmin  compatibility  issue  workaround  github  linux 
5 weeks ago by ezequiel
"The Battery installed is not supported by this system..." T470 : thinkpad
[...] No problems whatsoever until today. Now suddenly when I booted the system I got a black screen with the error message:

The battery installed is not supported by this system and will not charge. Please replace the battery with the correct Lenovo battery for this system.
2018  forumthread  reddit  laptop  battery  issue  workaround  windows  ubuntu  linux  links  tips  hardwaresupport  tool  debian  mint 
5 weeks ago by ezequiel
Hack Correlation: Non-genuine battery in Lenovo X230
[...] Second, the battery is suited for an X220 model, not X230.
Third - and most importantly - the battery is a fake, with less than the advertised capacity.

If you still decide to continue, then read on. Some nice people have managed to decrypt the EC firmware inside the Lenovo laptops and allow for a way to rewrite it:
https://github.com/hamishcoleman/thinkpad-ec [...]
2017  blogpost  laptop  battery  tips  howto  hacking  windows  windows10  ubuntu  linux  links  tool  screenshots  issue  workaround  bios  firmware  patches  hardwaresupport 
5 weeks ago by ezequiel
How to configure KODI to run in windowed mode from command line? - Ask Ubuntu
Q: I am running Kodi via XServer from 2-monitor remote conputer. When Kodi starts, it occupies entire 2 monitor are and absolutely useless.

It has a config to run in windowed mode, but how to activate it from command line? [...]
2016  forumthread  stackexchange  issue  configuration  cli  example  tips  gui  hardwaresupport  windows  linux  xorg  x11  xbmc 
5 weeks ago by ezequiel
ThinkWiki - Wiki for IBM/Lenovo ThinkPad users
This is ThinkWiki, the Wiki Web for IBM/Lenovo ThinkPad users. Here you find anything you need to install your favourite Linux distribution on your ThinkPad. Windows users shouldn't run away, there's a lot of useful information for them as well. Some Linux information for Mac users also can be found here.
wiki  articles  info  resources  issue  workaround  configuration  sysadmin  howto  guide  hardwaresupport  battery  bios  firmware  drivers  linux  keyboard  drm  install  installation  ubuntu  debian  hardware  reference  documentation  links  kernelpatches  kernelmodule  support  mailinglist  software  scripts  tools  laptop 
5 weeks ago by ezequiel
Project 294899064488 has been scheduled for deletion and cannot be used for API calls · Issue #736 · jdf76/plugin.video.youtube · GitHub
Q: Since today I'm unable to playing any video on Corelec 9.2.1.

It seems that this youtube extension project is on the way to be deleted in Google's API access. [...]

A: Using your own API keys is the only way to resolve this at this moment. For information on how to do this, see https://github.com/jdf76/plugin.video.youtube/wiki/Personal-API-Keys

Edit: For users that only require playback and don't use the add-on to browse content, https://github.com/enen92/script.tubecast may be an alternative solution for you.

Edit: Additional information [...]
xbmc  extension  issue  workaround  links  google  security  api  2020  forumthread  tips  github  youtube 
5 weeks ago by ezequiel
RPI falls back to 1280x720 from x1024. - Raspberry Pi Forums
Q: I have an HDMI->VGA converter module connected to my 'pi, as I have a bunch of TFT VGA monitors lying around, but no HDMI ones.

When I boot the 'pi with the cable attached, it comes up nicely in 1280x1024 as I told it to:

hdmi_drive=1
hdmi_group=2
hdmi_mode=35
hdmi_force_hotplug=1
config_hdmi_boost=4
disable_overscan=1

(hdmi_mode=35 is 1280x1024@60Hz in group 2)
However, somehow, the mode drops to a 60Hz 1280x720 mode when the monitor is not connected during boot. I was hoping to prevent these problems by specifying hdmi_force_hotplug=1, and directly specifying a mode that I want.
Why does it drop to a lower resolution if the monitor is not connected?
Just to be sure: the /proc/cmdline file shows "fbheight=720", so it is not my VGA converter that isn't booted correctly and somehow converting the 1280x1024 mode into 1280x720 (as if such a cheap piece of electronics would be capable of such a feat).
2012  forumthread  booting  configuration  sysadmin  linux  raspbian  raspberrypi  hardwaresupport  issue  workaround 
5 weeks ago by ezequiel
13.04 - Touchpad stopped working out of the blue - Ask Ubuntu
Q: So, I'm watching "The Walking Dead" and all of the sudden I lose control of my mouse through the touchpad. At first it was just for my user. I could reboot my system and switch to another user and use it just fine. [...]

$ sudo modprobe -r psmouse && sudo modprobe psmouse proto=imps

After this command, I regained control of my mouse but the computer didn't recognize it as a touchpad. I thought if I rebooted again, it may do the trick. So after I rebooted, the mouse went completely kaput. I cannot get the mouse to work at all now even though I've tried the command several times. I've tried different users and it's still the same.

A: 1. [...] synclient Touchpadoff=0 [...]
A: 2. [...] sudo apt-get install --reinstall xserver-xorg-input-synaptics [...]
A: [...]
synaptics  hardwaresupport  ubuntu  2013  forumthread  stackexchange  cli  tool  linux  debian  mint  issue  workaround  xorg 
5 weeks ago by ezequiel
Kodi playback is choppy and laggy 400% kodi.bin usage - Raspberry Pi Forums
Q: Hello i think that after my last rpi-update suddenly i cannnot watch any video in kodi....either through my usb devices or iptv, netflix,etc.. i have rpi3b+ and kodi 18.3 (multimedia repo) with raspbian buster. The cpu usage is 100% with extreme temps. i set fake gl or full with no result..If i set legacy i have not X(in raspi-config).

A: Kodi Leia 18.3 for RPi4 with Raspbian Buster plays well , videos not choppy, audio (although HDMI and Analog only, DAC HATs not supported) also in sync with video.
gpu memory set at 264 [...]
xbmc  memory  forumthread  2019  issue  workaround  tips  releaserelated  raspberrypi  hardwaresupport  sysadmin  configuration  booting  linux  gpu 
5 weeks ago by ezequiel
FAQ · tmux/tmux Wiki · GitHub
PLEASE NOTE: most display problems are due to incorrect TERM! Before
reporting problems make SURE that TERM settings are correct inside and
outside tmux.
tmux  faq  tips  example  configuration  terminal  issue  textui  curses  linux  unix  wikientry  github 
6 weeks ago by ezequiel
Can't resize or move windows on Raspberry Pi - Stack Overflow
Q: I am using the Raspberry Pi Model 3 B+ and there was recently an update( I did not record what it was doing or what it was called) and upon reboot it mentioned that there was a previous version saved somewhere(did not take note of where this was at). Not thinking much of the update I tried to move windows around and they would not move. I found to try the Alt button and dragging and that is not working.
2018  2019  forumthread  raspberrypi  lxde  windowmanager  issue  workaround  stackexchange  raspbian  x11 
6 weeks ago by ezequiel
Docker-compose.yml and custom script after entrypoint (before command) · Issue #205 · docker-library/wordpress
Q: I have fairly simple need, and have been struggling with this many hours now. I want to run some script after entrypoint, and before command. I've tried running it as a command but no luck. [...]
2017  configuration  docker  tool  tips  issue  workaround  github  example  howto 
6 weeks ago by ezequiel
Execute a command after run · Issue #1809 · docker/compose · GitHub
Q: It will be very helpful to have something like "onrun" in the YAML to be able to run commands after the run. Similar to moby/moby#8860 [...]
2015  github  issue  workaround  scripting  example  cli  configuration  docker  tips  sysadmin  automation  forumthread  tool 
6 weeks ago by ezequiel
(Solved) Flaky wifi with WRT1900ACS v2 and Android phones - Installing and Using OpenWrt - OpenWrt Forum
Q: I have a wrt1900acs v2 running the latest wifi drivers packaged by @eduperez and it is giving me nothing but problems.

Specifically my Android phones simply refuse to stay connected. Recently it's gotten to the point where it hardly will even connect at all and I've turned it off so that my older tp-link devices are the only APs. We've had hot weather, and I wonder if that's relevant because it was never this bad before.

Rebooting the WRT device seems to fix the problem for a few hours. [...]
2018  forumthread  wifi  android  issue  router  openwrt  workaround  tips  configuration  sysadmin  networking  hardwaresupport 
6 weeks ago by ezequiel
I've Bricked My Netgear DG834G v3 - Please Help - OpenWrt Forum Archive
Q: I am hoping someone here more wise then me can help me unbrick my Netgear DG834G v3 Router.

Here are some details I have pulled from the router before I bricked it. [...]
forumthread  2009  router  hacking  firmware  links  issue  workaround  jtag  cli  example  linux  hardware  electronics 
6 weeks ago by ezequiel
Successful unbricking of DG834 DG834G (v4) modems - Netgear
Q: Hi.. thought I'd share my experiences with successfully unbricking these Netgear modems

The usual symptoms are the flashing red/green power light and sometimes the default landing page of the Upgrade Firmware page. [...]
forumthread  2010  2014  router  hacking  firmware  links  issue  workaround 
6 weeks ago by ezequiel
dhcpcd - ArchWiki
dhcpcd is a DHCP and DHCPv6 client. It is currently the most feature-rich open source DHCP client, see the home page for the full list of features.
dhcp  wikientry  arch  linux  configuration  issue  workaround  sysadmin  networking  cli  example  tips  links 
7 weeks ago by ezequiel
linux - How to disable AAAA lookups? - Server Fault
Q: ... to compensate for broken DNS servers that are outside our control.

Our problem: We deploy embedded devices that collect sensor data at various, mostly IPv4-only sites. Some sites have poorly maintained networks, e.g. misconfigured or otherwise broken DNS caches and/or firewalls that either ignore AAAA queries altogether, or respond to them with broken replies (e.g. wrong source IP!). As an external supplier to the facilities department, we have next to no influence on the (sometimes reluctant) IT departments. The chances of them fixing their DNS servers/firewalls any time soon are minuscule.

The effect on our device is that with each gethostbyname(), the processes have to wait until the AAAA queries time out, at which point some processes have already timed out their connection attempts altogether.
2014  forumthread  stackexchange  networking  dns  ipv6  configuration  tips  sysadmin  issue  workaround  linux  debian  api  c 
8 weeks ago by ezequiel
domain name system - How to prevent delays associated with IPv6 AAAA records? - Server Fault
Q: Our Windows servers are registering IPv6 AAAA records with our Windows DNS servers. However, we don't have IPv6 routing enabled on our network, so this frequently causes stall behaviours.

Microsoft RDP is the worst offender. When connecting to a server that has a AAAA record in DNS, the remote desktop client will try IPv6 first, and won't fall back to IPv4 until the connection times out. Power users can work around this by connecting to the IP address directly. Resolving the IPv4 address with ping -4 hostname.foo always works instantly. [...]
2013  ipv6  forumthread  issue  workaround  links  stackexchange  windows  rdp  firewall  networking  compatibility  tips  sysadmin  configuration  dns 
8 weeks ago by ezequiel
Happy Eyeballs - Wikipedia
Happy Eyeballs (also called Fast Fallback) is an algorithm published by the IETF which can make dual-stack applications (those that understand both IPv4 and IPv6) more responsive to users by attempting to connect using both IPv4 and IPv6 at the same time (preferring IPv6), thus avoiding the usual problems faced by users with imperfect IPv6 connections or setups.
rfc  wikipedia  wikientry  reference  article  internet  ipv6  firewall  networking  issue  workaround  links  browser 
8 weeks ago by ezequiel
[SOLVED] disable AAAA response for a given domain - General - Pi-hole Userspace
Q: Is it possible to configure Pi-hole to return only A and not AAAA for a given domain?
The use case is pretty simple - IPv6 is provided via tunnel (HE broker) and accessing local (== in-country) resources via IPv6 is not desirable.
(me: returning '[::]' for every host in a domain does avoid a client attempting to contact a host outside of the local network, but the DNS server (dnsmasq) still produces a valid AAAA record/response, therefore some clients might attempt to still contact a host, and they'll be reaching a local(/ly forwarded?) server)
forumthread  issue  workaround  dnsmasq  dns  configuration  sysadmin  networking  linux  unix  example  2018 
8 weeks ago by ezequiel
download files from luci ( use LuCI as file share ) · Issue #846 · openwrt/luci
Q: I've uploaded some files in my OpenWrt root , /etc , /tmp directories.
I want user to be able to download uploaded files from from the above directories.
How can i give a download URL to user, to download that files?
github  openwrt  issue  workaround  tips  example  configuration  webserver  downloads  links  howto  guide  screenshots  router  serverapp  sysadmin  networking  forumthread  2016 
8 weeks ago by ezequiel
/etc/config/luci seems to be corrupt, unable to find section 'main' · Issue #2231 · openwrt/luci · GitHub
Q:
* OpenWrt 18.06.1 on a WRT3200ACM
* Sometimes, when I try to access the main page on the router, I get this error:

/usr/lib/lua/luci/dispatcher.lua:230: /etc/config/luci seems to be corrupt, unable to find section 'main'
stack traceback:
[C]: in function 'assert'
/usr/lib/lua/luci/dispatcher.lua:230: in function 'dispatch'
/usr/lib/lua/luci/dispatcher.lua:127: in function </usr/lib/lua/luci/dispatcher.lua:126>

However, "/etc/config/luci" looks fine, and just rebooting the device fixes the issue. [...]
2018  issue  workaround  router  openwrt  github  sysadmin  webapp 
8 weeks ago by ezequiel
OpenWrt Project: Netgear R8000
Status:
* First supported in 15.05 release
* 15.05 could fail to boot on device with NAND bad blocks (fixed for 15.05.1 release and in trunk)
* Second data partition (79 MiB) not available in OpenWrt
* For a proper performance use:
* radio0 for the higher 5 GHz band (channel 149 or something else, depending on country)
* radio2 for the lower 5 GHz band (channel 48, or something like that and lower)
netgear  router  openwrt  hardwaresupport  howto  install  installation  cli  example  tips  sysadmin  build  firmware  downloads  links  resources  guide  article  info  issue  workaround 
8 weeks ago by ezequiel
Limiting access to ssh - Google Groups
Q: I'd like to limit access to ssh to GCE console (so the browser based SSH works) and to our own networks. Is there a specific network mask I can use to allow connections from GCE console?
2015  forumthread  issue  workaround  example  cli  tips  sysadmin  networking  firewall  google.cloud  cloudcomputing  ssh  links  software 
9 weeks ago by ezequiel
1661973 – Sudo cannot authenticate user through PAM
Q: [...]
sudo: backuppc : PAM account management error: Authentication service
cannot retrieve authentication info ; TTY=pts/0 ; PWD=/root ;
USER=root ; COMMAND=/bin/rsync -d /home /tmp/
[...]

A: Adding backuppc via "pwck" fixed the issue. I am now running sudo version 1.8.3-23-3.
[...]
running 'pwck -r' after distro version changes will become part of my routine.
2018  issue  workaround  security  sudo  cli  example  forumthread  redhat  centos  pam  linux  2019  tool  configuration  sysadmin 
9 weeks ago by ezequiel
systemd-nspawn and sh: can't access tty; job control turned off · Issue #1431 · systemd/systemd
Q: Trying to launch alpine container on CoreOS via toolbox and getting sh: can't access tty; job control turned off warning. I've read about it in BusyBox FAQ, which didn't work for me, and tried this, also without any luck.

This works without any issues nor tweaks with docker. Is there some parameter that should be passed to nspawn like --interactive with docker? Or is this something completely different?

A: [...] toolbox getty -nl /bin/sh 0 /dev/console [...]
2015  2016  forumthread  issue  workaround  cli  example  tips  sysadmin  coreos  tool  github  linux  systemd  links 
10 weeks ago by ezequiel
CoreOS: containers not restarting after reboot · Issue #3241 · docker/compose
A: This was indeed a configuration change within CoreOS. For the benefit of others, the solution was to enable the Docker service in systemd:

# systemctl enable docker.service
# systemctl start docker.service
coreos  docker  booting  issue  workaround  cli  example  tips  2016  forumthread  github 
10 weeks ago by ezequiel
Removed Container Still Attached to Network · Issue #33156 · moby/moby
Q: I've got a removed container tying up an endpoint name in the bridged network, and I can't remove the container from the network since the container no longer exists.

The issue could most likely be resolved by clearing everything out and starting it up again but due to #32613 that would result in data loss so I'm avoiding that. Using a different name for the container allows it to be started but this is not ideal.

A: [...] Have you tried the -f / --force option on docker network disconnect? docker network disconnect <network> <endpoint-id>, so in your case; [...]
issue  docker  networking  configuration  workaround  forumthread  2017  linux  sysadmin  tips  example  github 
10 weeks ago by ezequiel
How to specify Memory & CPU limit in docker compose version 3 - Stack Overflow
Q: I am unable to specify CPU & memory for services specified in version 3.

With version 2 it works fine with "mem_limit" & "cpu_shares" parameters under the services . But it fails while using version 3 , putting them under deploy section doesn't seem worthy unless i am using swarm mode.

Can somebody help?
docker  fileformats  tool  howto  tips  example  issue  workaround  cpu  memory  virtualisation  security  sysadmin  cli  links  forumthread  stackexchange 
10 weeks ago by ezequiel
Docker and IPtables - sysadmin stuff
TL;DR; By default, docker daemon appends iptables rules for forwarding. For this, it uses a filter chain named DOCKER.
2015  blogpost  firewall  sysadmin  docker  compatibility  issue  workaround  cli  example  tips  networking  linux  iptables 
11 weeks ago by ezequiel
How to fix the Docker and UFW security flaw - TechRepublic
It has been discovered the Docker doesn't always honor UFW rules. Jack Wallen demonstrates and shows how to configure Docker so that it will.

If you use Docker on Linux, chances are your system firewall might be relegated to Uncomplicated Firewall (UFW). If that's the case, you may not know this, but the combination of Docker and UFW poses a bit of a security issue. Why? Because Docker actually bypasses UFW and directly alters iptables, such that a container can bind to a port. This means all those UFW rules you have set won't apply to Docker containers.

Let me demonstrate this.

I'm going to set up UFW (running on Ubuntu Server 16.04), so that the only thing it will allow through is SSH traffic. To do this, I open a terminal and issue the following commands: [...]
2018  blogpost  firewall  sysadmin  ufw  docker  compatibility  issue  workaround  cli  example  tips  networking  linux  iptables 
11 weeks ago by ezequiel
linux - Keep SSH session alive - Stack Overflow
A: #1: The ssh daemon (sshd), which runs server-side, closes the connection from the server-side if the client goes silent (i.e., does not send information). To prevent connection loss, instruct the ssh client to send a sign-of-life signal to the server once in a while.

The configuration for this is in the file $HOME/.ssh/config, create it if the configuration file does not exist. To send the signal every four minutes (240 seconds) to the remote host, put the following that configuration file:

Host remotehost:
HostName remotehost.com
ServerAliveInterval 240

[...]

A: #2: [...] If you want to set the keep alive for the server, add this to /etc/ssh/sshd_config:

ClientAliveInterval 60
ClientAliveCountMax 2

[...]
2014  2016  forumthread  stackexchange  ssh  configuration  tips  example  networking  issue  workaround  linux  unix  windows  macosx  remote 
12 weeks ago by ezequiel
how to install any software in coreos ? - Google Groups
A: On CoreOS everything is done inside of a container. For your use case, the easiest would probably be to use a systemd-nspawn container (the easiest way to do this for beginners is just to run the script "toolbox.sh").

As an alternative you can also use the Gentoo stage 3 which includes the GCC, Make, and all of the other development tools you would expect.
2015  forumthread  coreos  software  installation  howto  linux  docker  cli  tips  issue  workaround  gentoo  sysadmin 
12 weeks ago by ezequiel
Squid - Users - Possible Bug? "parameters()" syntax in acl dstdomain results in rule not working?
A: [...]
> I finally realized there appeared to be something wrong with the
> "parameters" handling of the external file, and turned it into:
>
> acl WHITELIST dstdomain "/etc/squid/whitelist.txt"
>
> With that one change it worked properly.
>
> Is this a known bug?

IIRC, to use parameters(), you need to turn
configuration_includes_quoted_values on: [...]
emailmessage  2018  squid  issue  fileformats  configuration  workaround  tips  networking  sysadmin  proxy 
12 weeks ago by ezequiel
unix - How to remove duplicate lines in YAML format configuration files? - Stack Overflow
Q: I have a bunch of manifest/yaml files that may or may not have these key value pair duplicates:

...
app: activity-worker
app: activity-worker
...

I need to search through each of those files and find those duplicates so that I can remove one of them. [...]

A: What you call YAML, is not YAML. The YAML specification very explicitly states that keys in a mapping must be unique, and your keys are not: [...]

[...] If you have such faulty "YAML" files, the best way to clean them up is using the round-trip capabilities of ruamel.yaml (disclaimer: I am the author of that package), and its ability to switch except/warn on faulty input containing duplicate keys. You can install it for your Python (virtual environment) using: [...]
tool  cli  links  2018  forumthread  yaml  fileformats  textprocessing  tips  example  stackexchange  python  issue  workaround 
january 2020 by ezequiel
OpenSSH moduli – ENTROPUX!
While playing around with a small and customized Debian based system, I noticed that the following log message was seen every time a user logged on via SSH:

WARNING: /etc/ssh/moduli does not exist, using fixed modulus

So what is this moduli file and why should you keep one of those around?
2014  blogpost  ssh  security  math  encryption  links  history  hacking  issue  workaround  cli  tool  howto  tips  sysadmin  example  unix  linux 
december 2019 by ezequiel
How to unlock account for public key ssh authorization, but not for password authorization? - Unix & Linux Stack Exchange
Q: The ssh won't let me login, because account is locked. I want to unlock the user on my server for public key authorization over ssh, but do not enable password-ed login. [...]

A: Unlock the account and give the user a complex password as @Skaperen suggests.
Edit /etc/ssh/sshd_config and ensure you have: [...]
2015  ssh  security  unix  linux  pam  sysadmin  remote  forumthread  stackexchange  issue  workaround  tips  example  configuration  cli 
december 2019 by ezequiel
Bug #881137 “UFW does not clean iptables setting from /etc/ufw/b...” : Bugs : ufw package : Ubuntu
Q: [...] And again and postrouting is never deleted when ufw is stopped and added again when stared. Same happen if I stop ufw firewall with: $ stop ufw. nat lines are not cleaned. [...]

A: As a workaround, add a flush for the nat chains you want flushed at beginning of the section like this:

*nat
:POSTROUTING ACCEPT [0:0]
-F POSTROUTING
-A POSTROUTING -o eth0 -j MASQUERADE
COMMIT

Warrning: This WILL also delete rules which may have been put there by other tools! ONLY do this if ufw is the only tool managing the specific tables / chains (here: nat POSTROUTING)
2015  issue  workaround  sysadmin  iptables  ufw  ubuntu  debian  configuration  networking  booting  systemd  example  tips  forumthread 
december 2019 by ezequiel
Cannot login to Docker account - Stack Overflow
Q: [...] However, when I try to save my image to the Docker hub, when I try to login, using:

# docker login

I get the following error message:

error getting credentials - err: exit status 1, out: `GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.secrets was not provided by any .service files`

I did not get any error messages, when I created my image on the remote server. [...]

A: As this is the currently selected answer, I think people should try @Anish Varghese solution below first as it seems to be the easiest. You only need to install the gnupg2 and pass packages:

# sudo apt install gnupg2 pass

If it doesn't work, then you can try my original solution here: [...]
2018  forumthread  stackexchange  issue  workaround  security  ubuntu  ubuntu.xenial  dbus  freedesktop  sysadmin  packages  example  cli  tips  2019 
december 2019 by ezequiel
Re: [squid-users] ipcCreate: fork: (12) Cannot allocate memory from Amos Jeffries on 2011-03-21 (squid-users)
>>> Squid has started to NOT come back up after log rotate. Here is
>>> snippett from cache.log.
>>> Machine has 1G ram and cache_mem is set to 500MB,
>>
>> Squid uses fork() instead of vfork() to spawn helpers, on some OS the
>> fork() implementation prevents extremely huge amounts of virtual
>> memory being "allocated" (even though it is neither allocated nor used).
>
> I think you mean that on some OS the form implementation 'results in'
> rather than 'prevents'
>
> on linux this is the 'overcommit' option, on by default in the kernel,
> but many people think it makes their systems more reliable to disable it.
2011  squid  memory  issue  mailinglistpost  kernel  docker  sysadmin  configuration  linux  proxy 
december 2019 by ezequiel
some kind of screen corruption · Issue #1040 · tmux/tmux
Q: [...] I'm executing '/', then repeating that search few times with n and after that I'm using move commands. You can notice some kind of corruption on screen - it looks like some of the lines are duplicated until vim repaints them. For completness, here I'm trying to reproduce this with 2.3, where everything works correctly: [...]

A: [townba commented on 17 Aug 2017]
I suspect that the three emulators that show the problem don't implement everything correctly.
Can you try adding the line:

set -ags terminal-overrides ",xterm-*:csr@"

to your .tmux.conf and see if that helps?
2017  github  issue  terminal  screen  tmux  workaround  configuration  links  gui  textui  linux  unix 
december 2019 by ezequiel
tinycc-devel - Fedora 30 and atexit results in error
Q: Trying to compile a program that uses atexit in Fedora 30 (gcc version 9.1.1 20190503, glibc 2.29), results in a tcc error.
---
tcc: error: undefined symbol '__dso_handle'

A: [...] Including crtbegin.o (for symbol __dso_handle) and crtend.o (for symbol __TMC_END__) makes tcc compile ok and the binary works.

$ tcc ../atexit.c /usr/lib/gcc/x86_64-redhat-linux/9/crtbegin.o /usr/lib/gcc/x86_64-redhat-linux/9/crtend.o
tcc  linking  issue  workaround  mailinglistpost  2019  linux  amd64  compiler  cli  example 
november 2019 by ezequiel
Bug #1839947 “hgview crashes with error AttributeError: 'phaseca...” : Bugs : hgview package : Ubuntu
A: [...] I think this might be related to a more recent version of mercurial unsupported by hgview 1.9.0
Can you try to reproduce with a more recent version of hgview ? https://pypi.org/project/hgview/ (1.10.7 for example). For debian packages you can try out the repo hosted by logilab (no service garantee).
mercurial  gui  textui  x11  software  debian  ubuntu  mint  packages  downloads  2019  issue  workaround  compatibility  repository  links  linux 
november 2019 by ezequiel
tcl - "can't read:variable is array" error in ns2 - Stack Overflow
In Tcl, $varName means “read from the variable called varName” and is not a general reference to the variable (unlike some other languages, notably Perl and PHP, which do rather different things). Reading from a whole array, instead of an element of that array, is always an error in Tcl.
2013  tcl  issue  forumthread  stackexchange  example  scripting 
october 2019 by ezequiel
« earlier      
per page:    204080120160

related tags

abi  acestream  acpi  adobe  advocacy  alsa  amazon  amazon.aws  amazon.boto  amazon.s3  amd64  amiga  analysis  android  android.app  antivirus  apache  api  apparmor  apple  applications  apps  apt  arch  architecture  archived.version  arduino  arm  article  articles  astaro  asus  atheros  audio  autofs  automation  autotools  awk  backports  backup  badmicrosoft  bash  battery  bbc  benchmark  beos  bestpractice  bios  bitcoin  blogpost  bluetooth  boost  boot  booting  browser  bsd  bug  bugfix  bugs  build  buildgenerator  burning  c  c++  c++11  calibre  caveats  ccache  cd  cdrom  centos  chrome.browser  chromium  chroot  citrix  clang  cli  cloudcomputing  cmake  cms  codecoverage  codecs  codingstandards  colour  com  commodore  community  compatibility  compiler  compiz  compression  concurrency  configuration  configure  console  converter  coreos  cpu  crash  crosscompile  crossplatform  cryptography  ctags  culture  cups  curses  customize  cygwin  dash  database  dbus  debian  debian.jessie  debian.lenny  debian.squeeze  debian.stretch  debian.wheezy  debianpkg  debug  debugger  deployment  design  desktop  development  dhcp  directx  distro  djgpp  dll  dns  dnsmasq  docker  documentation  dos  dosbox  dosemu  dotnet  download  downloads  dpkg  dpmi  driver  drivers  drm  dump  dvd  dynamicloader  e2guardian  ebook  ebooks  ebuild  ecryptfs  editor  education  eeepc  ekiga  electronics  emacs  email  emailmessage  emailthread  embedded  emulation  emulator  encryption  enlightenment  environment  ev.contrib  example  ext4  extension  faq  fedora  fileformats  filemanager  filesystem  filetype:pdf  firefox  firefox3  firewall  firmware  fix  flash  font  fonts  forensics  forum  forumpost  forums  forumthread  fossadvocacy  fotopic.net  framework  free  freebsd  freedesktop  freedom  freemcboot  freenx  freesoftware  freeware  ftp  fuse  gamepad  games  gaming  gcc  gdb  gentoo  german  gimp  git  github  gitlab  glib  glibc  gnome  gnome3  gnu  google  google.cloud  gpg  gpio  gpu  graphics  grub  gtk  gtk2  gtk3  gui  guide  hack  hacking  hacks  haiku  harddisk  hardware  hardwaresupport  history  homebrew  hosting  hotwo  howto  hp  hp2133  html  http  https  humax.hdr.fox.t2  humax.pvr  i3wm  icewm  ide  ie  im  image  info  install  installation  intel  interesting  internals  international  internationalisation  internet  ipc  iphone  ipod  iptables  ipv6  iso  issue  issuetracker  java  javascript  jekyll  jekyll.bootstrap  joystick  jtag  kb  kde  kernel  kernelmodule  kernelpatches  keyboard  knowledgetree  kobo.reader  kobo.reader.app  koreader  kvm  language  laptop  latex  leapsecond  legal  libraries  library  libreoffice  libtool  license.gplv3  licensing  linking  links  linksys  linux  linux.containers  lisp  livecd  livedvd  logging  lua  lubuntu  lxc  lxde  mac  macosx  macosx.elcapitan  madwifi  mailinglist  mailinglistpost  make  manual  math  mc  media  mediaplayer  mem.allocator  memory  memorycard  memtest  mercurial  metadata  microemacs  microsoft  midori.browser  mingw  mint  mobilereading  monero  mono  motherboard  motif  mount  mouse  mozilla  mp3  mr  msdn  msoffice  msoutlook  multiarch  multimedia  multiplatform  multitasking  ndiswrapper  neovim  netgear  network  networking  nfs  nis  node.js  nomachine  ntp  nvi  nvidia  nx  odf  officeapp  oldversion  ood  openbox  openbsd  opengl  openoffice  opensource  openssl  openwatcom  openwrt  opl.ps2  os  os2  package  packagemanager  packages  packaging  palmos  pam  partition  pascal  patch  patches  pci  pda  pdf  people  performance  photography  photos  php4  php5  pictures  player  plucker  plugin  plugins  portage  porting  posix  power  powermanagement  powerpc  ppa  presentation  printing  privacy  productivity  profiling  programming  proprietary  proxy  pulseaudio  pvr  python  python.pip  qa  qemu  qt  questions  radio  raid  ralink  raspberrypi  raspbian  rawformat  rdp  reader  reciva  reddit  redhat  redis  reference  registry  releaserelated  remote  repair  replaygain  repository  resources  retro  review  rfc  ripping  rockbox  rom  router  rpc  rpm  ruby  ruby.gem  rust  rvm  samba  sansa  sansa.clip+  sansa.fuze+  scm  screen  screenshots  script  scripting  scripts  sdk  sdl  search  security  selenium  serialport  server  serverapp  sharedlibraries  shell  shopping  sip  sis671  slackware  slashdot  slitaz  snes  software  solaris  songbird  sony.prs.t2  sonyreader  sound  source  sourcecode  sourceforge  sparc  spec  spotify  spreadsheet  sqlite  squid  ssh  ssl  stackexchange  standards  statistics  stl  storage  streaming  streamingaudio  subversion  sudo  support  suse  synaptics  sysadmin  systemd  systemtap  tcc  tcl  tcpip  tech  technology  templates  terminal  terraform  test  testversion  tex  text  textprocessing  textui  themes  threads  time  tips  tls  tmux  tool  toolchain  tools  topfield  tornado.python  tracing  ttf  tutorial  tutorials  ubuntu  ubuntu.bionic  ubuntu.hardy  ubuntu.intrepid  ubuntu.jaunty  ubuntu.karmic  ubuntu.lucid  ubuntu.maverick  ubuntu.natty  ubuntu.oneiric  ubuntu.precise  ubuntu.quantal  ubuntu.raring  ubuntu.saucy  ubuntu.trusty  ubuntu.utopic  ubuntu.vivid  ubuntu.wily  ubuntu.xenial  udev  ufw  ui  uk  unichrome  unicode  unittest  unix  unofficial  upgrade  upnp  usb  v4l  vagrant  valgrind  vcsh  vg.plat.ps2  vi  via  vice  video  videodb  vim  virtualbox  virtualisation  visualstudio  visualstudio6  visualstudio2005  visualstudio2013  vm  vmware  vmx  vnc  voip  vpn  wayland  web  webapp  webcam  webkit  webserver  wifi  wiki  wikiengine  wikientry  wikipedia  windbg  windowmanager  windows  windows7  windows8  windows10  windowsvista  windowsxp  wine  winecompatible  wireless  wlan  wordperfect  wordprocessor  workaround  wxwidgets  x2go  x11  x86  xbmc  xfce  xorg  xquartz  xrdp  xterm  xubuntu  yaml  youtube  yum  zip  zsh 

Copy this bookmark:



description:


tags: