ezequiel + debian   455

How to Install Adobe Acrobat Reader on Ubuntu 18.04 Bionic Beaver Linux - LinuxConfig.org
The objective is to install Adobe Acrobat Reader on Ubuntu 18.04 Bionic Beaver Linux.

Please note that Adobe no longer supports Acrobat Reader for Linux. The latest native Linux version is 9.5.5 dated from 26/04/2013. From this reason you should refrain using/installing Adobe Acrobat Reader if possible to avoid potential vulnerabilities and hacker exploits.
adobe  reader  fileformats  software  linux  debian  ubuntu  ubuntu.bionic  mint  howto  installation  tips  example  sysadmin  cli  blogpost  2018  x86  amd64 
12 days ago by ezequiel
xfce - Xubuntu: black screen after lock screen (light-locker, lightdm, logind, xfce4-power-manager) - Ask Ubuntu
Q: [...] The problem is that when my laptop goes into lock screen (or maybe suspend but I always disable that in power management options so it shouldn't), then it is quite common that I am not able to login back to it. Screen stays black after opening lid and pressing a button. [...]

A: The issue is due to lightlocker and XFCE no longer playing well.

I was able to fix this issue by upgrading to XFCE 4.14 from the Xubuntu staging PPA, removing light-locker and installing xfce4-screensaver. Please note I did this from a clean install of 18.04.3, so you might need to restore any changed settings.

sudo add-apt-repository ppa:xubuntu-dev/staging
sudo apt update
sudo apt upgrade
sudo apt remove light-locker
sudo apt install xfce4-screensaver
xfce  desktop  issue  workaround  packages  cli  sysadmin  debian  ubuntu  mint  security  forumthread  stackexchange  2019  ui  tips  example 
13 days ago by ezequiel
lock goes to black screen · Issue #114 · the-cavalry/light-locker
Q: [...] Since last update, unlocking with light-locker-command --lock displays a black screen with a cursor, then cursor disappear. Before it worked like a charm.
From black screen get lightm lock screen I have to switch to tty1 using Ctrl+Alt+F1 and then Ctrl + Alt + F7 [...]
desktop  software  issue  workaround  packages  arch  linux  debian  ubuntu  mint  links  forumthread  2018  github  security  ui  gui  xfce 
13 days ago by ezequiel
ndiswrapper / Wiki / HowTos
This page contains general information on setting up Ndiswrapper in general. If you have an article or information pertaining to a specific network device then please add it to that device's page.
ndiswrapper  howto  tips  linux  wifi  driver  drivers  arch  centos  debian  gentoo  knoppix  slackware  slitaz  suse  opensolaris  ubuntu  eeepc  links  online 
13 days ago by ezequiel
#870126 - ecryptfs-mount-private: mount: No such file or directory - Debian Bug report logs
Q: I have setup the standard home ~/Private directory. It looks like it is confused about which key to use.

For the last few months or so, I get this (key IDs changed but consistent in report):

$ ecryptfs-mount-private

[...]

A: [...]

1. The problem is the user keyring not being linked
to the session keyring. keyctl link @u @s is a much easier workaround. [...]
2017  issue  workaround  ecryptfs  encryption  forumthread  cli  example  configuration  pam  filesystem  debian  ubuntu  security  tips 
24 days ago by ezequiel
encryption - SSH remote user need to be logged in? - Ask Ubuntu
Q: I'm trying to set up an SSH server. I put my public key in the authorized_keys file, made sure the permissions were correct, etc.

When I restart the server (really just Ubuntu 12.04 desktop) and I ssh to it without first logging in on the server, I am asked for a password. If, however, I log into the server, I can ssh without being asked for a password. [...]

A: The problem usually arises if your home directory is encrypted. The usual solution is to put your keys in a directory other than your home directory, and point your sshd_config file to it.

For example:

1. Move your authorized_keys file on the server from /home/buck/.ssh/authorized_keys to something like /etc/ssh/keys/buck/authorized_keys [...]
2012  forumthread  stackexchange  ecryptfs  encryption  ubuntu  debian  security  sysadmin  filesystem  issue  workaround  tips  example  configuration  ssh  remote 
24 days ago by ezequiel
encryption - Will changing password re-encrypt my home directory? - Ask Ubuntu
Q: I need to change my user password. Do I need to take any extra steps for my encrypted home directory to become inaccessible with my old password and only accessible with my new password?

A: There is no need to re-encrypt your home directory, and no further steps need to be taken.

Your home directory is not directly encrypted with your password. Instead, the passphrase used to encrypt the home directory is itself encrypted with your password.

When you change your password, the home directory passphrase is re-encrypted with your new password, so you should have continued access to your files with the new password. [...]
2011  forumthread  stackexchange  ecryptfs  encryption  ubuntu  debian  ubuntu.lucid  security  cli  sysadmin  filesystem  issue  workaround  tips  example 
24 days ago by ezequiel
linux mint - mount: No such file or directory with encrypted recovery - Unix & Linux Stack Exchange
Q: [...] Nothing I’ve tried seems to work and I don’t have the original mounting seed. I’ve also tried sudo ecryptfs-recover-private but my system then just says No such file or directory:

frankenmint@honeybadger /home $ sudo ecryptfs-recover-private
INFO: Searching for encrypted private directories (this might take a while)...
INFO: Found [/home/.ecryptfs/frankenmint/.Private].
Try to recover this directory? [Y/n]: y
INFO: Found your wrapped-passphrase
Do you know your LOGIN passphrase? [Y/n] y
INFO: Enter your LOGIN passphrase...
Passphrase:
Inserted auth tok with sig [979c6cdf80d2e44d] into the user session keyring
mount: No such file or directory
ERROR: Failed to mount private data at [/tmp/ecryptfs.Hy3BV96c].

[...]

A: I found that running sudo bash and then running ecryptfs-recover-private as root (rather than via sudo) worked. Not sure why it should be any different.

Edit:
TL;DR:

# ecryptfs-unwrap-passphrase /mnt/crypt/.ecryptfs/user/.ecryptfs/wrapped- passphrase - | ecryptfs-add-passphrase --fnek -
< Type your login password here >
Inserted auth tok with sig [aaaaaaaaaaaaaaaa] into the user session keyring
Inserted auth tok with sig [bbbbbbbbbbbbbbbb] into the user session keyring

You will not see a prompt and must type your login password, blind, into the above command. [...]
2016  forumthread  stackexchange  cli  sysadmin  encryption  filesystem  ubuntu  debian  mint  tips  issue  workaround  example  guide  linux  security  mount  ubuntu.xenial  ubuntu.trusty  ubuntu.bionic  ecryptfs 
25 days ago by ezequiel
Suspend - Debian Wiki
This page gathers bits of information about getting software suspend to work in Debian. Because the core system components change rapidly among Debian versions, software suspend works differently on different versions of Debians. This page is divided according to Debian versions from new to old.

For more reading material, see also the links at the bottom of this page about hibernate and suspend.
debian  wikientry  documentation  links  reference  guide  tips  example  sysadmin  powermanagement  configuration  arch  gentoo  gnome  suse  debug  linux  acpi  laptop  security 
4 weeks ago by ezequiel
linux - How to turn off Wireless power management permanently - Unix & Linux Stack Exchange
Q: In Linux Mint 17.3 / 18 iwconfig says the power management of my wireless card is turned on. I want to turn it off permanently or some workaround on this issue.

sudo iwconfig wlan0 power off works, until I reboot the laptop.

Also, if I randomly check iwconfig, sometimes it's on, despite I did run this command. [...]

A #1: Open this file with your favorite text editor, I use nano here:

sudo nano /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

By default there is:

[connection]
wifi.powersave = 3

Change the value to 2. Reboot for the change to take effect. [...]
2016  forumthread  stackexchange  linux  ubuntu  mint  debian  networking  software  configuration  sysadmin  powermanagement  usb  issue  workaround  cli  links  documentation  tips  example  wifi 
4 weeks ago by ezequiel
Installing EFL on Ubuntu
This tutorial describes several ways to install EFL on your system. You will only need to use one of these. Select your chosen method using the index on the right.
enlightenment  libraries  library  windowmanager  install  installation  links  downloads  source  debian  ubuntu  ubuntu.bionic  ubuntu.xenial  ubuntu.trusty  ubuntu.precise  linux  packages  howto  guide  example  cli  sysadmin  x11  wayland  ppa  build 
4 weeks ago by ezequiel
Tp smapi - ThinkWiki
The tp_smapi kernel module exposes some features of the ThinkPad hardware/firmware via a sysfs interface. Currently, the main implemented functionality is control of battery charging and extended battery status. The tp_smapi software package also includes an improved version of the HDAPS driver. The underlying hardware interfaces are SMAPI and direct access to the embedded controller.
battery  laptop  wikientry  kernelmodule  installation  gentoo  debian  ubuntu  mint  issue  workaround  tips  example  configuration  hardwaresupport  compatibility 
5 weeks ago by ezequiel
mkottman/acpi_call: A linux kernel module that enables calls to ACPI methods through /proc/acpi/call. Now with support for Integer, String and Buffer parameters.
A kernel simple module that enables you to call ACPI methods by writing the method name followed by arguments to /proc/acpi/call.

This module is to be considered a proof-of-concept and has been superseeded by projects like bbswitch. It allows you to tamper with your system and should be used with caution.

Want to use acpi_call via graphic interface? [Click here]
2012  github  laptop  battery  ubuntu  fedora  debian  links  source  kernelmodule  hardwaresupport  powermanagement 
5 weeks ago by ezequiel
linrunner.de: TLP – Linux Advanced Power Management
TLP brings you the benefits of advanced power management for Linux without the need to understand every technical detail. TLP comes with a default configuration already optimized for battery life, so you may just install and forget it. Nevertheless TLP is highly customizable to fulfil your specific requirements.

TLP packages are available for Arch, Debian, Fedora, Gentoo, openSUSE, Ubuntu and further. You're welcome if you want to package TLP for other distributions. Please take a look at the developer documentation.
battery  powermanagement  sysadmin  linux  documentation  reference  tips  example  tool  cli  performance  laptop  hardwaresupport  guide  faq  workaround  source  links  reviews  software  arch  debian  fedora  gentoo  suse  ubuntu  installation  packages 
5 weeks ago by ezequiel
"The Battery installed is not supported by this system..." T470 : thinkpad
[...] No problems whatsoever until today. Now suddenly when I booted the system I got a black screen with the error message:

The battery installed is not supported by this system and will not charge. Please replace the battery with the correct Lenovo battery for this system.
2018  forumthread  reddit  laptop  battery  issue  workaround  windows  ubuntu  linux  links  tips  hardwaresupport  tool  debian  mint 
5 weeks ago by ezequiel
tp-smapi - ThinkWiki
The tp_smapi kernel module exposes some features of the ThinkPad hardware/firmware via a sysfs interface. Currently, the main implemented functionality is control of battery charging and extended battery status. The tp_smapi software package also includes an improved version of the HDAPS driver. The underlying hardware interfaces are SMAPI and direct access to the embedded controller.

This driver uses undocumented features and direct hardware access, so it may work unreliably or even damage your hardware; but so far no such damage has been reported.

If you are installing on a recent Thinkpad that has an Ivy Bridge or newer processor (X230, T430, T530, etc.), tp_smapi will not work. You will be mostly limited to thinkpad-acpi capabilities. You can however set battery charge thresholds with tpacpi-bat.
laptop  hardwaresupport  kernelmodule  api  documentation  reference  tips  example  sysadmin  configuration  howto  info  resources  install  installation  gentoo  debian  ubuntu  suse  scripts  links  battery  tool  tools  wikientry  linux 
5 weeks ago by ezequiel
ThinkWiki - Wiki for IBM/Lenovo ThinkPad users
This is ThinkWiki, the Wiki Web for IBM/Lenovo ThinkPad users. Here you find anything you need to install your favourite Linux distribution on your ThinkPad. Windows users shouldn't run away, there's a lot of useful information for them as well. Some Linux information for Mac users also can be found here.
wiki  articles  info  resources  issue  workaround  configuration  sysadmin  howto  guide  hardwaresupport  battery  bios  firmware  drivers  linux  keyboard  drm  install  installation  ubuntu  debian  hardware  reference  documentation  links  kernelpatches  kernelmodule  support  mailinglist  software  scripts  tools  laptop 
5 weeks ago by ezequiel
13.04 - Touchpad stopped working out of the blue - Ask Ubuntu
Q: So, I'm watching "The Walking Dead" and all of the sudden I lose control of my mouse through the touchpad. At first it was just for my user. I could reboot my system and switch to another user and use it just fine. [...]

$ sudo modprobe -r psmouse && sudo modprobe psmouse proto=imps

After this command, I regained control of my mouse but the computer didn't recognize it as a touchpad. I thought if I rebooted again, it may do the trick. So after I rebooted, the mouse went completely kaput. I cannot get the mouse to work at all now even though I've tried the command several times. I've tried different users and it's still the same.

A: 1. [...] synclient Touchpadoff=0 [...]
A: 2. [...] sudo apt-get install --reinstall xserver-xorg-input-synaptics [...]
A: [...]
synaptics  hardwaresupport  ubuntu  2013  forumthread  stackexchange  cli  tool  linux  debian  mint  issue  workaround  xorg 
5 weeks ago by ezequiel
vcgencmd - Raspberry Pi Documentation
vcgencmd is a command line utility that can get various pieces of information from the VideoCore GPU on the Raspberry Pi. Much of the information available is only of use to Raspberry Pi engineers, but there are a number of very useful options available to end users that will be described here.
cli  tool  raspberrypi  hardwaresupport  gpu  linux  debian  sysadmin  documentation  reference  example 
6 weeks ago by ezequiel
apt - How do I find the reverse dependency of a package? - Ask Ubuntu
Q: I was wondering if it was possible to check what package another package is a dependency of. [...]

A: You can use apt-cache rdepends --installed jetty to see what depends on jetty. [...]
2010  2019  apt  packagemanager  cli  tool  example  sysadmin  forumthread  stackexchange  links  linux  debian  ubuntu  mint 
6 weeks ago by ezequiel
panubo/vsftpd - Docker Hub
This is a micro-service image for VSFTPD.

There are a few limitations but it will work if you are using host networking --net host or have a direct/routed network between the Docker container and the client.
ftp  serverapp  docker.container  linux  amd64  debian  router  hardwaresupport 
6 weeks ago by ezequiel
apt - Find (and reinstall) packages with corrupted files (without breaking anything) - Ask Ubuntu
Q: [...] Such a such situation may occur if you have to work-around dependency problems with dpkg --force-*. One could also reproduce such a situation by deleting a file from /usr as root.

Is there a simple way to verify whether all files belonging to an installed package are present?

If a such a problem package is found, aptitude reinstall fixes the problem.
2011  2014  forumthread  stackexchange  ubuntu  debian  tools  packagemanager  cli  example  tips  linux  configuration  apt 
7 weeks ago by ezequiel
debian - Cannot update APT list: "repository no longer has a Release file" - Unix & Linux Stack Exchange
Q: I cannot run apt-get update as I encounter the following error:

# apt-get update
Hit:1 http://ftp.br.debian.org/debian testing InRelease
Ign:2 http://security.debian.org/debian-security testing/updates InRelease
Err:3 http://security.debian.org/debian-security testing/updates Release
404 Not Found [IP: 151.101.92.204 80]
Reading package lists... Done
E: The repository 'http://security.debian.org/debian-security testing/updates Release' no longer has a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Repository 'http://ftp.br.debian.org/debian testing InRelease' changed its 'Codename' value from 'buster' to 'bullseye'
N: This must be accepted explicitly before updates for this repository can be applied. See apt-secure(8) manpage for details.
[...]
2019  forumthread  stackexchange  apt  packagemanager  security  sysadmin  cli  example  tips  debian  ubuntu  mint  repository 
7 weeks ago by ezequiel
Wireguard - Debian Wiki
Wireguard is an extremely simple yet fast and modern VPN that utilizes state-of-the-art cryptography. It can be a useful replacement for IPSec or OpenVPN.
networking  debian  ubuntu  mint  wireguard  configuration  example  cli  howto  sysadmin  linux  vpn  security  tools  links  wikientry  guide 
7 weeks ago by ezequiel
WireGuard in NetworkManager – Thomas Haller's Blog
NetworkManager 1.16 got native support for WireGuard VPN tunnels (NEWS). WireGuard is a novel VPN tunnel protocol and implementation that spawned a lot of interest. Here I will not explain how WireGuard itself works. You can find very good documentation and introduction at wireguard.com.
networking  debian  gnome  ubuntu  mint  2019  blogpost  wireguard  configuration  example  cli  howto  sysadmin  linux  vpn  security  tools  guide 
7 weeks ago by ezequiel
Sunxi-tools - linux-sunxi.org
Tools for working with Allwinner (sunxi) ARM processors
allwinner.a80  allwinner  tool  tools  wikientry  howto  tips  guide  example  cli  hardwaresupport  rom  debug  spec  arm  linux  debian  fedora  ubuntu  mint 
8 weeks ago by ezequiel
InstallingDebianOn/Allwinner - Debian Wiki
Support for boards using the Allwinner "sunxi" (sun4i, sun5i, sun6i, sun7i, sun8i) family of processors, e.g. A10, A13, A31/A31s, A20, A23/A33, etc.
debian  hardwaresupport  install  installation  cli  example  howto  guide  sysadmin  hacking  links  tips  wikientry  linux 
8 weeks ago by ezequiel
linux - How to disable AAAA lookups? - Server Fault
Q: ... to compensate for broken DNS servers that are outside our control.

Our problem: We deploy embedded devices that collect sensor data at various, mostly IPv4-only sites. Some sites have poorly maintained networks, e.g. misconfigured or otherwise broken DNS caches and/or firewalls that either ignore AAAA queries altogether, or respond to them with broken replies (e.g. wrong source IP!). As an external supplier to the facilities department, we have next to no influence on the (sometimes reluctant) IT departments. The chances of them fixing their DNS servers/firewalls any time soon are minuscule.

The effect on our device is that with each gethostbyname(), the processes have to wait until the AAAA queries time out, at which point some processes have already timed out their connection attempts altogether.
2014  forumthread  stackexchange  networking  dns  ipv6  configuration  tips  sysadmin  issue  workaround  linux  debian  api  c 
8 weeks ago by ezequiel
User identifier - Wikipedia
Unix-like operating systems identify a user by a value called a user identifier, often abbreviated to user ID or UID. The UID, along with the group identifier (GID) and other access control criteria, is used to determine which system resources a user can access. The password file maps textual user names to UIDs. UIDs are stored in the inodes of the Unix file system, running processes, tar archives, and the now-obsolete Network Information Service. In POSIX-compliant environments, the command-line command id gives the current user's UID, as well as more information such as the user name, primary user group and group identifier (GID).
wikipedia  wikientry  debian  linux  unix  bsd  freebsd  history  solaris  sun  compatibility  hardwaresupport  sysadmin  info  links  reference 
11 weeks ago by ezequiel
Nginx as forward proxy for HTTPS - Super User
Q: While I was able to successfully configure nginx to proxy HTTP traffic (using this guide), all attempts to proxy HTTPS requests resulted in code 400 (Bad Request). [...]

A: If you don't mind compiling nginx from source, you could install ngx_http_proxy_connect_module. The following worked for me in Debian 9 "Stretch" on a Raspberry Pi (after I added deb-src URLs to /etc/apt/sources.list and did apt-get update): [...]
2013  forumthread  stackexchange  nginx  extension  build  howto  proxy  privacy  tls  ssl  http  configuration  example  tips  links  linux  debian  raspbian  raspberrypi  docker.container 
12 weeks ago by ezequiel
Bug #881137 “UFW does not clean iptables setting from /etc/ufw/b...” : Bugs : ufw package : Ubuntu
Q: [...] And again and postrouting is never deleted when ufw is stopped and added again when stared. Same happen if I stop ufw firewall with: $ stop ufw. nat lines are not cleaned. [...]

A: As a workaround, add a flush for the nat chains you want flushed at beginning of the section like this:

*nat
:POSTROUTING ACCEPT [0:0]
-F POSTROUTING
-A POSTROUTING -o eth0 -j MASQUERADE
COMMIT

Warrning: This WILL also delete rules which may have been put there by other tools! ONLY do this if ufw is the only tool managing the specific tables / chains (here: nat POSTROUTING)
2015  issue  workaround  sysadmin  iptables  ufw  ubuntu  debian  configuration  networking  booting  systemd  example  tips  forumthread 
december 2019 by ezequiel
Changing the Hostname of Your Linux Instance - Amazon Elastic Compute Cloud
When you launch an instance, it is assigned a hostname that is a form of the private, internal IPv4 address. A typical Amazon EC2 private DNS name looks something like this: ip-12-34-56-78.us-west-2.compute.internal, where the name consists of the internal domain, the service (in this case, compute), the region, and a form of the private IPv4 address.
amazon.aws  configuration  sysadmin  linux  cli  example  tools  amazon.linux  debian  ubuntu  networking  documentation  reference 
december 2019 by ezequiel
Install No-IP Client for Linux using the Snap Store | Snapcraft
Keep your current IP address in sync with your No-IP host or domain with No-IP's Dynamic Update Client (DUC). (Unoffical)
dns  internet  cli  tool  snap.app  unix  linux  links  ubuntu.bionic  ubuntu  arch  fedora  mint  centos  suse  debian  redhat  package  example  sysadmin  networking 
december 2019 by ezequiel
Repology
Repology monitors a huge number of package repositories and other sources comparing packages versions across them and gathering other information. Repology shows you in which repositories a given project is packaged, which version is the latest and which needs updating, who maintains the package, and other related information. Repology might be useful
repository  searchable  compatibility  releaserelated  linux  debian  ubuntu  mint  redhat  centos  fedora  suse  arch  gentoo  bsd  freebsd  packages  links  downloads 
november 2019 by ezequiel
LogilabDebianRepository (Logilab.org) (includes hgview (curses/qt))
Logilab.org's Debian and Ubuntu repositories
Accessing Debian and Ubuntu repositories to install Logilab's free software.
Installing Logilab.org's software on Debian or Ubuntu

Some of Logilab.org's free software projects are included in Debian (e.g. logilab-common and pylint at least). If your want to get software that is not included in Debian or just get latest releases quicker, add one of these repositories to your /etc/apt/sources.list file.
mercurial  gui  textui  x11  software  debian  ubuntu  mint  packages  2019  repository  links  howto  guide  reference  example  tips  linux 
november 2019 by ezequiel
Bug #1839947 “hgview crashes with error AttributeError: 'phaseca...” : Bugs : hgview package : Ubuntu
A: [...] I think this might be related to a more recent version of mercurial unsupported by hgview 1.9.0
Can you try to reproduce with a more recent version of hgview ? https://pypi.org/project/hgview/ (1.10.7 for example). For debian packages you can try out the repo hosted by logilab (no service garantee).
mercurial  gui  textui  x11  software  debian  ubuntu  mint  packages  downloads  2019  issue  workaround  compatibility  repository  links  linux 
november 2019 by ezequiel
Boot-Repair - Community Help Wiki
Boot-Repair is a simple tool to repair frequent boot issues you may encounter in Ubuntu like when you can't boot Ubuntu after installing Windows or another Linux distribution, or when you can't boot Windows after installing Ubuntu, or when GRUB is not displayed anymore, some upgrade breaks GRUB, etc.
booting  tool  repair  sysadmin  harddisk  linux  ubuntu  debian  freesoftware  livecd  links  download  software  gui  grub  wikientry  howto  guide  tips 
october 2019 by ezequiel
boot-repair / Home / Home
Boot-Repair, simple tool to recover access to your Operating Systems.

* Easy-to-use (repair in 1 click ! )
* Free (GPL open-source license)
* Helpful (Boot-Info summary to get help by email or on your favorite forum)
* Safe (automatic backups)
* Reliable (400.000 users per year)
* Can recover access to Windows (XP, Vista, Windows7, Windows8, Windows10).
* Can recover access to Debian, Ubuntu, Mint, Fedora, OpenSuse, ArchLinux...
* Can recover access to any OS (Windows, MacOS, Linux..) if your PC contains Debian, Ubuntu, Mint, Fedora, OpenSuse, ArchLinux, or derivative.
* Can repair MBR-locked OEM computer boot if the original bootsector has been saved by Clean-Ubiquity
* Can repair the boot when you have the "GRUB Recovery" error message
* Options to reinstall GRUB2/GRUB1 bootloader easily (OS by default, purge, unhide, kernel options..)
* and much more ! (UEFI, SecureBoot, RAID, LVM, Wubi, filesystem repair...)
booting  tool  repair  sysadmin  harddisk  linux  ubuntu  debian  freesoftware  sourceforge  license.gpl  livecd  links  download  software  gui  grub 
october 2019 by ezequiel
Code7R/icewm: A window manager designed for speed, usability, and consistency
This is a fork of the IceWM CVS on sourceforge. It includes all changes from the icewm-1-3-BRANCH branch, greatly enhanced EWMH/ICCCM compliance, as well as patches collected from Arch Linux, Debian, pld-linux, the IceWM bug list, and various other GitHub forks. [...]
(me: contains a number of debian-specific git branches with debianpkg-related changes)
github  source  icewm  debian  debianpkg  patches  windowmanager  linux  unix  x11 
october 2019 by ezequiel
dual boot - How can I repair grub? (How to get Ubuntu back after installing Windows?) - Ask Ubuntu
A: [...] I've seen various instructions for replacing GRUB by mucking around with GRUB commands or some such, but to me the easiest way is to simply chroot into your install and run update-grub. chroot is great because it allows you to work on your actual install, instead of trying to redirect things here and there. It is really clean.
2011  2017  grub  booting  issue  workaround  installation  howto  tips  sysadmin  ubuntu  debian  livecd  livedvd  example  harddisk  partition  configuration  linux  windows  forumthread  stackexchange 
september 2019 by ezequiel
zerof/lenny64 - Docker Hub
Simple build was made with debootstrap.

sudo debootstrap --variant=minbase --components=main --include=inetutils-ping,iproute
--arch=amd64 lenny lenny64 http://archive.debian.org/debian

tar -C lenny64 -c . | docker import - lenny64

Before build install debian-archive-keyring (ubuntu and debian OS's).
debian.lenny  debian  docker.container  linux  amd64 
september 2019 by ezequiel
Tip: 24-bit True Color Terminal + tmux + vim
The version of vim in -current is 24-bit color ready, and the version of tmux (2.2) in -current/testing is also 24-bit color ready. I'm happily using them together. Want a 24-bit terminal emulator/tmux/vim combination? Read on.
2016  forumthread  tmux  vim  colour  tips  configuration  shell  scripting  example  linux  unix  ubuntu  debian  cli  terminal 
september 2019 by ezequiel
compression - How can I reduce the file size of a scanned PDF file? - Ask Ubuntu
Q: I have a 72.9MB PDF file that I need to shrink into under 500KB.
The file was a JPEG image that I had scanned, and then converted to pdf.

A: [...] Here are a couple of script and command-line solutions. Use as you see fit.
* reduce-pdf-file-size-linux
* shrinkpdf
* compress-a-pdf-with-pdftk
* pdfcompress
pdf  fileformats  tool  tools  cli  links  unix  linux  ubuntu  debian  forumthread  stackexchange  2012  2015  2017  compression 
september 2019 by ezequiel
IceWM | Window Manager
IceWM is a window manager for the X Window System. The goal of IceWM is speed, simplicity, and not getting in the user’s way. It comes with a taskbar with pager, global and per-window keybindings and a dynamic menu system. Application windows can be managed by keyboard and mouse. Windows can be iconified to the taskbar, to the tray, to the desktop or be made hidden. They are controllable by a quick switch window (Alt+Tab) and in a window list. A handful of configurable focus models are menu-selectable. Setups with multiple monitors are supported by RandR and Xinerama. IceWM is very configurable, themable and well documented. It includes an optional external background wallpaper manager with transparency support, a simple session manager and a system tray. IceWM is available on popular Linux distributions like Debian, Ubuntu, Arch, OpenSUSE, Gentoo, Slackware, CentOS and also compiles on most *BSDs.
icewm  windowmanager  x11  xorg  releaserelated  development  links  howto  tips  build  github  debian  ubuntu  arch  suse  slackware  centos  redhat  bsd  linux  2019 
august 2019 by ezequiel
Debian User Forums • View topic - Defrag FAT from Linux?
A: You could try this under QEMU:
http://partitionlogic.org.uk/
Atleast it works for me; installation instructions: [...]
qemu  forumthread  debian  tool  tools  links  filesystem  freeware  example  tips  2007 
august 2019 by ezequiel
Ubuntu · golang/go Wiki
The Go project's official download page is at https://golang.org/dl/.
If you're using Ubuntu 16.04 LTS, 18.04 LTS, 18.10 or 19.04, then you can use the longsleep/golang-backports PPA and install Go 1.12. [...]
golang  wikientry  install  links  downloads  howto  guide  example  tips  ubuntu  ubuntu.xenial  ubuntu.bionic  ppa  repository  packages  debian 
august 2019 by ezequiel
#866019 - mc: Crash On SFTP Upload - Debian Bug report logs
When I try to upload a file with SFTP then MC crashes with following error:

mc:7228 GLib-ERROR ** /build/.../glib/gmem.c:100 failed to allocate ... bytes

Trace/Breakpoint

Jun 26 18:33:54 - kernel: [10139.526827] do_trap: 93 callbacks suppressed
Jun 26 18:33:54 - kernel: [10139.526834] traps: mc[7228] trap int3
ip:7f96dfacd261 sp:7ffec9304350 error:0
Jun 26 18:33:54 - kernel: [10139.526842] in
libglib-2.0.so.0.5000.3[7f96dfa7d000+112000]

Download is fine.

And there are some SFTP Protocol Error -31
debian  issue  links  mc  linux  remote  2017  ssh 
july 2019 by ezequiel
PCSX2: Not possible to run BIOS/Game
A: You just have to put the BIOS folder in the root of PCSX2
(example - C:\program files (x86)\pcsx2 0.9.7\bios)
then it should work!!
so have I sloved this problem..))))
2010  forumthread  issue  workaround  vg.plat.ps2  emulator  bios  linux  ubuntu  debian  windows  tips 
july 2019 by ezequiel
How to disable the touchpad? - Ask Ubuntu
Q: I want my touchpad to be disabled when I use my mouse. How can I do that? touchpad-indicator has stopped working on 11.10. It used to work on 11.04. Gnome3 is not a solution as I don't like it and find it buggy.
ubuntu  mint  debian  gnome  xfce  xorg  hardwaresupport  x11  linux  cli  example  tips  forumthread  stackexchange  2011 
july 2019 by ezequiel
[SOLVED] Trouble with faulty RAM, kernel "badram" parameter not effective on 64-bit flavour
Q: [...] 64-bit version of Ubuntu is entirely different story. First of, documentation says BadRAM pattern should be extended to 64-bits for x64 kernel, so in my case:

GRUB_BADRAM="0x0000b3a9feec,0xfffffffffffc"

However, changing it like this just makes the computer hang before it even reaches the Grub screen. So I tried just appending badram parameter to kernel command-line (extending it to 64-bits ofcourse), but it doesn't work as it should neither. Machine successfully boots, "free" command reports 4 KB of less memory, but apparently it doesn't blacklist the actual defective sectors of RAM, but some good ones I guess, judging from the fact that computer once again just hangs after few minutes. [...]
memory  issue  workaround  booting  kernel  linux  hardwaresupport  grub  configuration  sysadmin  forumthread  ubuntu  debian  amd64  example 
june 2019 by ezequiel
Redirect Linux sound to DLNA receivers using PulseAudio / 27 / 2015 / Archive / Magazine / Home - Ubuntu User
This is where DLNA comes into play. The protocol lets you stream multimedia data via the network. Streaming is really easy thanks to PulseAudio DLNA [1] if you have a DLNA-enabled AV receiver or another device with the necessary support, such as a home cinema PC or a Raspberry Pi with Kodi. The latest version of the DLNA server used with PulseAudio also supports Google's Chromecast dongle and (at least in theory) Sonos loudspeakers.
dlna  article  2015  ubuntu  linux  debian  howto  guide  audio  networking  pulseaudio  sysadmin  configuration  example 
june 2019 by ezequiel
Install snapd for Linux using the Snap Store | Snapcraft
Install, configure, refresh and remove snap packages. Snaps are 'universal' packages that work across many different Linux systems, enabling secure distribution of the latest apps and utilities for cloud, servers, desktops and the internet of things.
snap  sysadmin  packages  links  linux  ubuntu  arch  centos  redhat  mint  debian  fedora  suse 
june 2019 by ezequiel
chaifeng/ufw-docker: To fix the Docker and UFW security flaw without disabling iptables
Problem:

UFW is a popular iptables front end on Ubuntu that makes it easy to manage firewall rules. But when Docker is installed, Docker bypass the UFW rules and the published ports can be accessed from outside.

The issue is:

* UFW is enabled on a server that provides external services, and all incoming connections that are not allowed are blocked by default.
* Run a Docker container on the server and use the -p option to publish ports for that container on all IP addresses. For example: docker run -d --name httpd -p 0.0.0.0:8080:80 httpd:alpine, this command will run an httpd service and publish port 80 of the container to port 8080 of the server.
* UFW will not block all external requests to visit port 8080. Even the command ufw deny 8080 will not prevent external access to this port.
* This problem is actually quite serious, which means that a port that was originally intended to provide services internally is exposed to the public network.

Searching for "ufw docker" on the web can find a lot of discussion: [...]
ufw  firewall  ubuntu  debian  tool  cli  sysadmin  scripting  docker  automation  configuration  security  iptables  article  links  issue  workaround  license.gplv3  freesoftware  github 
june 2019 by ezequiel
Post-installation steps for Linux | Docker Documentation
This section contains optional procedures for configuring Linux hosts to work better with Docker.
docker  installation  configuration  booting  linux  debian  ubuntu  centos  fedora  redhat  howto  guide  sysadmin  cli  systemd  security 
june 2019 by ezequiel
Pass: The Standard Unix Password Manager
Password management should be simple and follow Unix philosophy. With pass, each password lives inside of a gpg encrypted file whose filename is the title of the website or resource that requires the password. These encrypted files may be organized into meaningful folder hierarchies, copied from computer to computer, and, in general, manipulated using standard command line file management utilities.
security  linux  unix  macosx  debian  ubuntu  redhat  fedora  centos  suse  gentoo  arch  freebsd  cli  sysadmin  gpg  downloads  info  links  software  compatibility  freesoftware  license.gplv2 
june 2019 by ezequiel
How do you add a certificate authority (CA) to Ubuntu? - Super User
Q: My work has decided to issue their own certificate authority (CA) to handle different aspects of our work securely without paying for certificates. [...]
ssl  tls  security  2012  forumthread  stackexchange  tips  cli  ubuntu  debian  linux  example  links  sysadmin 
may 2019 by ezequiel
install:nginx [DokuWiki]
You need to install nginx and php-fpm, if you are on a current release, this will be at least php7.0.

The nginx config below is based mostly on the sample configuration in this site here updated to work with current relases (tested with 16.04 LTS). With the image caching config from this site
nginx  documentation  configuration  howto  installation  debian  linux  ubuntu  ubuntu.xenial  windows  tips  sysadmin  wikientry  online  wikiengine 
may 2019 by ezequiel
How to start/stop iptables on Ubuntu? - Server Fault
Q: How can I start/stop the iptables service on Ubuntu?
I have tried:
service iptables stop
but it is giving "unrecognized service".
Why is it doing so? Is there any other method?
(me: several links and answers describing several methods to store firewall rules, for example: 'ufw', 'netfilter-persistent', etc.)
2010  iptables  tips  example  links  networking  security  ubuntu  debian  firewall  sysadmin  configuration  linux  stackexchange  forumthread 
may 2019 by ezequiel
Firewall [help.ubuntu.com]
The Linux kernel includes the Netfilter subsystem, which is used to manipulate or decide the fate of network traffic headed into or through your server. All modern Linux firewall solutions use this system for packet filtering.
firewall  ubuntu  linux  howto  tips  guide  links  software  sysadmin  security  debian  tool  tools 
may 2019 by ezequiel
raspbian - How do I set up networking/WiFi/static IP address? - Raspberry Pi Stack Exchange
A: This tutorial describes how to setup networking using the default network manager dhcpcd included in Raspbian since 2015-05-05.
It applies to the Foundation releases of Raspbian Stretch, Raspbian Jessie and the last Raspbian Wheezy. [...]
raspbian  raspberrypi  networking  sysadmin  linux  debian  howto  tips  example  links  configuration  dhcp  wifi  dns  stackexchange  forumthread  2015 
may 2019 by ezequiel
DebianFirewall - Debian Wiki
WARNING: iptables is being replaced by nftables

A network firewall is a set of rules to allow or deny passage of network traffic, through one or more network devices. A network firewall may also perform more complex tasks, such as network address translation, bandwidth adjustment, provide encrypted tunnels and much more related to network traffic.
iptables  cli  howto  sysadmin  tips  debian  linux  networking  firewall  security  wikientry  router 
may 2019 by ezequiel
Automatically loading iptables rules on Debian/Ubuntu · major.io
If you want your iptables rules automatically loaded every time your networking comes up on your Debian or Ubuntu server, you can follow these easy steps.
iptables  cli  howto  sysadmin  tips  backup  2009  blogpost  debian  linux  networking  firewall  security  automation 
may 2019 by ezequiel
nftables - Debian Wiki
nftables is a framework by the Netfilter Project that provides packet filtering, network address translation (NAT) and other packet mangling.

Two of the most common uses of nftables is to provide firewall support and NAT.

nftables replaces the iptables framework.
iptables  nftables  sysadmin  debian  wikientry  faq  links  info  tips 
may 2019 by ezequiel
Linux: Setup a transparent proxy with Squid in three easy steps - nixCraft
Y’day I got a chance to play with Squid and iptables. My job was simple : Setup Squid proxy as a transparent server. [...]
2006  squid  proxy  howto  blogpost  sysadmin  linux  guide  centos  debian  networking  redhat  fedora  ubuntu 
may 2019 by ezequiel
How To Forward Ports through a Linux Gateway with Iptables | DigitalOcean
In this guide, we'll demonstrate how to use iptables to forward ports to hosts behind a firewall by using NAT techniques. This is useful if you've configured a private network, but still want to allow certain traffic inside through a designated gateway machine. We will be using two Ubuntu 14.04 hosts to demonstrate this.
iptables  networking  proxy  2015  blogpost  ubuntu.trusty  ubuntu  debian  linux  cli  example  tips  howto  guide  sysadmin 
may 2019 by ezequiel
Filter Content on Your Home Network with E2guardian | Linux.com | The source for Linux information
[...] E2guardian works in conjunction with another caching proxy (e.g., Squid) and offers all the features you’d need in a home network content filter: [...]
proxy  configuration  blogpost  2015  howto  guide  sysadmin  networking  linux  debian  ubuntu  raspberrypi  raspbian  installation  e2guardian 
may 2019 by ezequiel
linux - No USB devices available in VirtualBox - Super User
Q: Oracle VirtualBox is unable to list/filter the USB devices attached to my system. As a result, the guest OS is not able to see any USB device either.

This is my configuration:

* Host: VirtualBox 5.0.0 r101573 on Ubuntu 14.04, with Oracle VM VirtualBox Extension Pack installed
* Guest: Windows 7, with VirtualBox Guest Additions installed
linux  ubuntu  debian  virtualbox  configuration  howto  tips  usb  issue  workaround  example  forumthread  stackexchange  2015  ubuntu.xenial  ubuntu.trusty  mint 
february 2019 by ezequiel
Linuxbrew | The Homebrew package manager for Linux
Linuxbrew is a fork of Homebrew, the macOS package manager, for Linux.

It can be installed in your home directory and does not require root access. The same package manager can be used on both your Linux server and your Mac laptop. Installing a modern version of glibc and gcc in your home directory on an old distribution of Linux takes five minutes.
homebrew  linux  packagemanager  opensource  debian  ubuntu  fedora  centos  cli 
october 2018 by ezequiel
home directory - Path for fonts? - Ask Ubuntu
Q: I searched already for this question and got a page on here where someone answered with "go to home/username/.fonts" or somesuch. I ran into a couple problems: [...]

(me: look into '/etc/fonts/fonts.conf', '/etc/fonts/conf.d/50-user.conf', '/etc/fonts/conf.d/*.conf' (look for '<dir>' entries))
2014  forumthread  stackexchange  ubuntu  debian  configuration  fonts  linux  tips  example 
september 2018 by ezequiel
AppImage | Linux apps that run anywhere
Download an application, make it executable, and run! No need to install. No system libraries or system preferences are altered. Can also run in a sandbox like Firejail.
[...]
Distribute your desktop Linux application in the AppImage format and win users running all common Linux distributions. Package once and run everywhere. Reach users on all major desktop distributions.
appimage  packaging  packages  tutorial  links  linux  amd64  x86  development  tool  cli  github  applications  apps  debian  ubuntu  mint  centos  redhat  suse  fedora  arch 
august 2018 by ezequiel
Ubuntu virtual terminal cursor style resetting - Super User
Q: I am running Ubuntu 14.04 and using one of the virtual terminals (TTY[1-6], accessible via Ctrl-Alt-F[1-6]); I want to permanently change the appearance of my cursor from the apparent default, a blinking underline, to a blinking box. I can change it temporarily, but it is consistently resetting when certain applications are run. [...]
(me: good explanation in the "accepted answer"; quoted excerpt from tmux(1) man page provided the only command that worked to fix tmux after neovim left the terminal in a "garbage-writing" state: printf '\033[0 q')
2016  forumthread  stackexchange  textui  terminal  configuration  issue  workaround  links  unix  linux  xterm  tmux  neovim  tips  example  debian  ubuntu  mint 
august 2018 by ezequiel
www.freeoffice.com - Linux tips & tricks
The applications in SoftMaker FreeOffice 2018 for Linux come in 32-bit and 64-bit versions, making them compatible with 32-bit (x86, 686) and 64-bit (x86_64, amd64) Linux.
freeware  linux  debian  mint  ubuntu  suse  fedora  productivity  officeapp  x11  tips  sysadmin  howto  x86  amd64  install  repository 
august 2018 by ezequiel
« earlier      
per page:    204080120160

bundles : computing

related tags

acpi  activism  adobe  advocacy  aix  allwinner  allwinner.a80  alpine  amazon.aws  amazon.linux  amd64  amiga  android.app  apache  api  apparmor  appimage  applications  apps  apt  arch  architecture  archive  archived.version  arm  article  articles  ascii  astaro  ati  audio  automation  autotools  backports  backup  bash  battery  bestpractice  binary  bios  bittorrent  blog  blogpost  booting  browsable  browser  bsd  bug  bugs  build  c  ccache  cd  cdbs  cdrom  centos  chat  cheatsheet  chrome.browser  chromebook  chromeos  chromium  chroot  cli  cloudcomputing  cmake  codec  codecs  colour  commercialsoftware  commodore  community  comparison  compatibility  compiler  compression  computer  computing  configuration  contrib  converter  cpu  crash  crosscompile  crossplatform  curses  cygwin  daily  darwin  dash  debian  debian.jessie  debian.lenny  debian.sid  debian.squeeze  debian.stretch  debian.wheezy  debianpkg  debug  debugger  deployment  design  desktop  desktopart  development  dhcp  diagrams  distro  djgpp  dlna  dns  docker  docker.container  documentation  dos  download  downloads  drawing  driver  drivers  drm  dvd  dynamicloader  e2guardian  e17  ebook  ebuild  ecryptfs  editor  education  eeepc  electronics  elf  emacs  email  emailmessage  embedded  emulation  emulator  encoding  encryption  energy  english  enlightenment  environment  europe  example  examples  executables  extension  facebook  faq  fedora  fileformats  filesystem  finnix  firefox  firewall  firmware  fix  font  fonts  forumpost  forumthread  fossadvocacy  free  freebsd  freedesktop  freedom  freenx  freesoftware  freespire  freeware  fsf  ftp  gamepad  games  gaming  gcc  gdb  geek  gentoo  german  gfdl  gimp  git  github  glibc  gnome  gnu  golang  google  government  gpg  gpio  gpu  graphics  grub  gtk  gtk2  gtk3  gui  guide  hacking  hacks  haproxy  harddisk  hardware  hardwaresupport  history  home.appliance  homebrew  hosting  howto  hpux  http  i3wm  icewm  ide  im  images  info  install  installation  intel  interesting  international  internet  interview  iphone  iptables  ipv6  irix  iso  issue  java  joystick  kde  kernel  kernelmodule  kernelpatches  keyboard  knoppix  kvm  language  laptop  latex  law  leapsecond  libraries  library  license  license.bsd  license.gpl  license.gplv2  license.gplv3  license.lgpl  links  linspire  linux  linux.containers  livecd  livedvd  localisation  lsb  ltsp  lvm  lxc  lxde  mac  mac.g4  macosx  magazine  mailinglist  mailinglistpost  make  mame  mandriva  manpage  manual  mc  media  mediaplayer  mem.allocator  memory  mercurial  metadata  microemacs  mint  mips  mirrors  mobile  monero  mount  mouse  movies  mp3  msoffice  multiarch  multimedia  multiplatform  music  ndiswrapper  neovim  netbsd  network  networking  news  nfs  nftables  nginx  nis  node.js  ntp  nx  officeapp  offline  oldversion  online  onvif  openbox  openbsd  opengl  opensolaris  opensource  openssl  openwrt  opera  optimisation  os  package  packagemanager  packages  packaging  palmos  pam  partition  patches  patents  pci  pdf  people  performance  photography  pictures  plan9  player  plugin  plugins  politics  portage  porting  posix  power  powermanagement  powerpc  ppa  printing  privacy  process  productivity  programming  proxy  pulseaudio  puppy  python  qa  qemu  qt  raid  raspberrypi  raspbian  raw  rdp  reader  reddit  redhat  reference  releaserelated  remote  repair  replaygain  repository  rescue  resources  reverseproxy  review  reviews  rockbox  rom  router  rpm  ruby  ruby.gem  rvm  scaling  scm  screen  screenshots  script  scripting  scripts  sdl  search  searchable  security  serialport  server  serverapp  sharedlibraries  shell  shop  skype  slackware  slashdot  slitaz  snap  snap.app  software  solaris  sound  source  sourcecode  sourceforge  spanish  sparc  spec  squid  ssd  ssh  ssl  stackexchange  standards  storage  streaming  subversion  sudo  sun  support  suse  synaptics  sysadmin  systemd  tcc  technology  terminal  testversion  tex  textprocessing  textui  themes  threads  time  tips  tls  tmux  tool  toolchain  tools  ttf  tutorial  tutorials  tv  ubuntu  ubuntu.bionic  ubuntu.hardy  ubuntu.lucid  ubuntu.oneiric  ubuntu.precise  ubuntu.quantal  ubuntu.raring  ubuntu.saucy  ubuntu.trusty  ubuntu.xenial  udev  ufw  ui  uk  uml  unix  upgrade  usa  usb  vagrant  vg.plat.ps2  vice  video  vim  virtual  virtualbox  virtualisation  vlc  vm  vm.appliance  vmware  vorbis  vpn  vulnerability  wayland  webapp  webcam  webserver  wifi  wiki  wikiengine  wikientry  wikipedia  windowmanager  windows  windows7  windowsxp  wine  winecompatible  wireguard  wireless  wireshark  workaround  wxwidgets  x2go  x11  x86  xbian  xbmc  xen  xfce  xml  xorg  xrdp  xterm  xubuntu  youtube  yum  zeroinstall 

Copy this bookmark:



description:


tags: