ezequiel + 2018   141

How to Install Adobe Acrobat Reader on Ubuntu 18.04 Bionic Beaver Linux - LinuxConfig.org
The objective is to install Adobe Acrobat Reader on Ubuntu 18.04 Bionic Beaver Linux.

Please note that Adobe no longer supports Acrobat Reader for Linux. The latest native Linux version is 9.5.5 dated from 26/04/2013. From this reason you should refrain using/installing Adobe Acrobat Reader if possible to avoid potential vulnerabilities and hacker exploits.
adobe  reader  fileformats  software  linux  debian  ubuntu  ubuntu.bionic  mint  howto  installation  tips  example  sysadmin  cli  blogpost  2018  x86  amd64 
5 days ago by ezequiel
lock goes to black screen · Issue #114 · the-cavalry/light-locker
Q: [...] Since last update, unlocking with light-locker-command --lock displays a black screen with a cursor, then cursor disappear. Before it worked like a charm.
From black screen get lightm lock screen I have to switch to tty1 using Ctrl+Alt+F1 and then Ctrl + Alt + F7 [...]
desktop  software  issue  workaround  packages  arch  linux  debian  ubuntu  mint  links  forumthread  2018  github  security  ui  gui  xfce 
6 days ago by ezequiel
exploit - How to disable NX on Linux - Super User
Q: I'm learning stack buffer overflow exploitation, and I later posted question Shellcode segmentation fault. about that executing shellcode from test program, or when injected to vulnerable program, causes segmentation violation. Now I found out that it might be caused by NX. When I search for this in dmesg I found this line:

[ 0.000000] NX (Execute Disable) protection: active
2018  forumthread  stackexchange  kernel  booting  security  grub  configuration  sysadmin  howto  x86  amd64  example  tips  links  linux  exploit  cpu  bios 
25 days ago by ezequiel
E22 built for ubuntu : Vsevolod Velichko
sample package names + versions:
* e17 0.22.4-0ubuntu2
* efl 1.21.1-0ubuntu4
enlightenment  ppa  ubuntu  ubuntu.cosmic  ubuntu.bionic  windowmanager  packages  x11  wayland  2018 
26 days ago by ezequiel
Enlightenment E21 PPA : Niko2040
Stable version of Enlightenment E21 and EFL.

For Debian Unstable you can use https://repo.4e.by

sample package names + versions:
* efl 1.20.7-0bionic0
* enlightenment 0.22.3-0bionic0
enlightenment  ppa  ubuntu  ubuntu.cosmic  ubuntu.bionic  windowmanager  packages  x11  wayland  2018 
26 days ago by ezequiel
FS#1960 : hostapd/netifd: multicast_to_unicast/hairpin not set for dynamic vlan, ap not in isolate mode
I noticed that multicast_to_unicast and hairpin_mode are not set on the dynamically created wlan interfaces, and the wireless ap is not running in isolate mode. This is because these interfaces are created by hostapd, unlike other wlan interfaces which are created from netifd/system-linux.

The attached patch fixes this:
- it sets ap_isolate for the hostapd interface, if the interface is using dynamic vlan
- it sets multicast_to_unicast and hairpin_mode after the dynamic interface is created

I haven’t handled the case where the isolate option is not set for the wifi interface, or where multicast_to_unicast is not set on the bridge, since this requires passing additional information to hostapd, and I wasn’t sure what the preferred way to do this would be. I’d probably overload the ap_isolate option to have value 2 mean that multicast_to_unicast and hairpin_mode should be set.
wifi  networking  openwrt  issue  workaround  forumthread  configuration  2018  patches 
29 days ago by ezequiel
Bought used x230 last week and new 9-cell battery and looking for TPL and tpacpi-bat and recommended thresholds. : thinkpad
Q: [...] I'm quite new here but a good suggestion would be highly appreciated. I want to get the maximum benefit of power comsumption for my x230 and best use of the new 9 cell battery. Can anyone give me some TLP configuration tips that you found works best and tpacpi-bat thresholds (since x230 onwards tp_smapi don't support) that will make the battery age longer? [...]
2018  reddit  forumthread  sysadmin  howto  tips  configuration  laptop  battery  hardwaresupport  hardware  bios 
4 weeks ago by ezequiel
Get the best out of you battery on linux : linux
[...] I noticed that battery life in Linux (Linux Mint 19.1 Cinnamon in my case) is WAY worse than in windows 10, I use my laptop more often to watch TV shows and movies and to browse the internet.

I have a small battery in my laptop, The battery when I'm using mint can't make it over 2 hours of light usage, while in windows 10 with same light usage the battery can make it over 4-4.5 hours. [...]
forumthread  reddit  powermanagement  optimisation  linux  ubuntu  software  tips  sysadmin  configuration  links  howto  guide  tool  tools  cli  wifi  networking  usb  laptop  battery  cpu  memory  2018  hardwaresupport  mint  desktop 
4 weeks ago by ezequiel
"The Battery installed is not supported by this system..." T470 : thinkpad
[...] No problems whatsoever until today. Now suddenly when I booted the system I got a black screen with the error message:

The battery installed is not supported by this system and will not charge. Please replace the battery with the correct Lenovo battery for this system.
2018  forumthread  reddit  laptop  battery  issue  workaround  windows  ubuntu  linux  links  tips  hardwaresupport  tool  debian  mint 
4 weeks ago by ezequiel
Battery gauge reset features implemented for Linux : thinkpad
So I wrote two crucial patches for Linux that enable the battery gauge to be reset, thus completely eliminating the need for Lenovo Power Manager. The patches are currently awaiting review, but for anyone curious here they are:

0: https://patchwork.kernel.org/patch/10396259/
1: https://patchwork.kernel.org/patch/10396265/
2: https://patchwork.kernel.org/patch/10396271/

I hope that the review process will pass without major issues. If anyone wants more details feel free to ask.
forumthread  reddit  linux  kernel  hardwaresupport  laptop  battery  kernelpatches  links  2018  acpi 
4 weeks ago by ezequiel
Can't resize or move windows on Raspberry Pi - Stack Overflow
Q: I am using the Raspberry Pi Model 3 B+ and there was recently an update( I did not record what it was doing or what it was called) and upon reboot it mentioned that there was a previous version saved somewhere(did not take note of where this was at). Not thinking much of the update I tried to move windows around and they would not move. I found to try the Alt button and dragging and that is not working.
2018  2019  forumthread  raspberrypi  lxde  windowmanager  issue  workaround  stackexchange  raspbian  x11 
5 weeks ago by ezequiel
Preparing Raspberry PI for JTAG Debugging – Sysprogs Tutorials
This tutorial shows how to prepare your Raspberry PI board for debugging with JTAG (we have tested this with Raspberry Pi 1, 2 and 3). Using JTAG will allow debugging the Linux kernel using hardware like Segger J-Link. As Raspberry PI board does not have a connector with a normal JTAG layout, preparing the board for JTAG debugging involves finding the correct pins and wiring them in the correct order. Follow the steps below for a complete walkthrough:
2018  blogpost  raspberrypi  jtag  debug  howto  guide  electronics  screenshots  software  windows  links  hardwaresupport 
5 weeks ago by ezequiel
port forwarding - iptables redirect outside requests to 127.0.0.1 - Unix & Linux Stack Exchange
The iptables rule you are using will work, but there is one additional change you need to make:

sysctl -w net.ipv4.conf.eth0.route_localnet=1
2014  2018  forumthread  iptables  linux  firewall  networking  configuration  sysadmin  cli  howto  tips  example  stackexchange 
5 weeks ago by ezequiel
(Solved) Flaky wifi with WRT1900ACS v2 and Android phones - Installing and Using OpenWrt - OpenWrt Forum
Q: I have a wrt1900acs v2 running the latest wifi drivers packaged by @eduperez and it is giving me nothing but problems.

Specifically my Android phones simply refuse to stay connected. Recently it's gotten to the point where it hardly will even connect at all and I've turned it off so that my older tp-link devices are the only APs. We've had hot weather, and I wonder if that's relevant because it was never this bad before.

Rebooting the WRT device seems to fix the problem for a few hours. [...]
2018  forumthread  wifi  android  issue  router  openwrt  workaround  tips  configuration  sysadmin  networking  hardwaresupport 
5 weeks ago by ezequiel
Four ways to connect a docker container to a local network · The Odd Bit
Update (2018-03-22) Since I wrote this document back in 2014, Docker has developed the macvlan network driver. That gives you a supported mechanism for direct connectivity to a local layer 2 network. I've written an article about working with the macvlan driver.
fedora  linux  docker  sysadmin  cli  tool  example  tips  networking  firewall  configuration  howto  blogpost  2018 
6 weeks ago by ezequiel
Add an addition persistent route on eth0 - Raspberry Pi Forums
Q: [...] I have tried adding a route command to dhcpcd.conf in a section called interface eth0 but as that interface is assigned dynamically I don't think it is read.

I would be happy to find a simple command line solution as I can script it to run when I want.
2018  raspberrypi  raspbian  dhcp  configuration  networking  sysadmin  howto  tips  links  forumthread  cli  example 
6 weeks ago by ezequiel
dnsmasq: How to provide route info to clients? | Ubiquiti Community
Q: [...] Does dnsmasq have a way to provide clients on ERX/eth0 with additional IPv4 routing info, beside the default route? I could not immediately spot that info in dnsmasq(8).

A: There is dhcp option 121, which does exactly what is needed:

dhcp-option=option:classless-static-route,1.2.3.0/24,4.3.2.1
dnsmasq  dhcp  serverapp  configuration  sysadmin  linux  unix  networking  example  tips  forumthread  2018 
6 weeks ago by ezequiel
[SOLVED] disable AAAA response for a given domain - General - Pi-hole Userspace
Q: Is it possible to configure Pi-hole to return only A and not AAAA for a given domain?
The use case is pretty simple - IPv6 is provided via tunnel (HE broker) and accessing local (== in-country) resources via IPv6 is not desirable.
(me: returning '[::]' for every host in a domain does avoid a client attempting to contact a host outside of the local network, but the DNS server (dnsmasq) still produces a valid AAAA record/response, therefore some clients might attempt to still contact a host, and they'll be reaching a local(/ly forwarded?) server)
forumthread  issue  workaround  dnsmasq  dns  configuration  sysadmin  networking  linux  unix  example  2018 
7 weeks ago by ezequiel
/etc/config/luci seems to be corrupt, unable to find section 'main' · Issue #2231 · openwrt/luci · GitHub
Q:
* OpenWrt 18.06.1 on a WRT3200ACM
* Sometimes, when I try to access the main page on the router, I get this error:

/usr/lib/lua/luci/dispatcher.lua:230: /etc/config/luci seems to be corrupt, unable to find section 'main'
stack traceback:
[C]: in function 'assert'
/usr/lib/lua/luci/dispatcher.lua:230: in function 'dispatch'
/usr/lib/lua/luci/dispatcher.lua:127: in function </usr/lib/lua/luci/dispatcher.lua:126>

However, "/etc/config/luci" looks fine, and just rebooting the device fixes the issue. [...]
2018  issue  workaround  router  openwrt  github  sysadmin  webapp 
7 weeks ago by ezequiel
1661973 – Sudo cannot authenticate user through PAM
Q: [...]
sudo: backuppc : PAM account management error: Authentication service
cannot retrieve authentication info ; TTY=pts/0 ; PWD=/root ;
USER=root ; COMMAND=/bin/rsync -d /home /tmp/
[...]

A: Adding backuppc via "pwck" fixed the issue. I am now running sudo version 1.8.3-23-3.
[...]
running 'pwck -r' after distro version changes will become part of my routine.
2018  issue  workaround  security  sudo  cli  example  forumthread  redhat  centos  pam  linux  2019  tool  configuration  sysadmin 
8 weeks ago by ezequiel
memory usage - What do the changes in `free` output from 14.04 to 16.04 mean? - Ask Ubuntu
Q: I noticed that the free command reporting has changed somewhere between Trusty and Xenial. Here is what `free -m' shows on one of my Trusty computers: [...]
2016  2018  ubuntu  ubuntu.trusty  ubuntu.xenial  memory  cli  tool  sysadmin  linux  kernel  tips  links  reference  info  forumthread  stackexchange 
10 weeks ago by ezequiel
ddos - iptables rules to counter the most common DoS attacks? - Server Fault
Q: Recently I've got a lot of small scale DoS attacks. I am wondering what iptables rules should I use to counter the most common DoS attacks, and generally secure my web server.
[...]
So appreciate your rules to block the most common attack vectors.
2012  2018  forumthread  stackexchange  iptables  linux  firewall  security  example  tips  sysadmin  networking  cloudcomputing  remote 
10 weeks ago by ezequiel
How to fix the Docker and UFW security flaw - TechRepublic
It has been discovered the Docker doesn't always honor UFW rules. Jack Wallen demonstrates and shows how to configure Docker so that it will.

If you use Docker on Linux, chances are your system firewall might be relegated to Uncomplicated Firewall (UFW). If that's the case, you may not know this, but the combination of Docker and UFW poses a bit of a security issue. Why? Because Docker actually bypasses UFW and directly alters iptables, such that a container can bind to a port. This means all those UFW rules you have set won't apply to Docker containers.

Let me demonstrate this.

I'm going to set up UFW (running on Ubuntu Server 16.04), so that the only thing it will allow through is SSH traffic. To do this, I open a terminal and issue the following commands: [...]
2018  blogpost  firewall  sysadmin  ufw  docker  compatibility  issue  workaround  cli  example  tips  networking  linux  iptables 
10 weeks ago by ezequiel
Create a Linux Swap File | Linuxize
Swap is a space on a disk that is used when the amount of physical RAM memory is full. When a Linux system runs out of RAM, inactive pages are moved from the RAM to the swap space.

Swap space can take the form of either a dedicated swap partition or a swap file. In most cases when running Linux on a virtual machine a swap partition is not present so our only option is to create a swap file.

This tutorial was tested on Linux systems with Ubuntu 18.04 and CentOS 7 but it should work with any other Linux distribution.
2018  blogpost  linux  memory  howto  guide  cli  sysadmin  configuration  tips  example 
11 weeks ago by ezequiel
Squid - Users - Possible Bug? "parameters()" syntax in acl dstdomain results in rule not working?
A: [...]
> I finally realized there appeared to be something wrong with the
> "parameters" handling of the external file, and turned it into:
>
> acl WHITELIST dstdomain "/etc/squid/whitelist.txt"
>
> With that one change it worked properly.
>
> Is this a known bug?

IIRC, to use parameters(), you need to turn
configuration_includes_quoted_values on: [...]
emailmessage  2018  squid  issue  fileformats  configuration  workaround  tips  networking  sysadmin  proxy 
11 weeks ago by ezequiel
The Four Essential Sections of an HAProxy Configuration - HAProxy Technologies
An HAProxy configuration file guides the behavior of your HAProxy load balancer. In this post, we demonstrate its four most essential sections.
haproxy  blogpost  2018  configuration  example  tips  links  tutorial  networking 
11 weeks ago by ezequiel
unix - How to remove duplicate lines in YAML format configuration files? - Stack Overflow
Q: I have a bunch of manifest/yaml files that may or may not have these key value pair duplicates:

...
app: activity-worker
app: activity-worker
...

I need to search through each of those files and find those duplicates so that I can remove one of them. [...]

A: What you call YAML, is not YAML. The YAML specification very explicitly states that keys in a mapping must be unique, and your keys are not: [...]

[...] If you have such faulty "YAML" files, the best way to clean them up is using the round-trip capabilities of ruamel.yaml (disclaimer: I am the author of that package), and its ability to switch except/warn on faulty input containing duplicate keys. You can install it for your Python (virtual environment) using: [...]
tool  cli  links  2018  forumthread  yaml  fileformats  textprocessing  tips  example  stackexchange  python  issue  workaround 
12 weeks ago by ezequiel
Cannot login to Docker account - Stack Overflow
Q: [...] However, when I try to save my image to the Docker hub, when I try to login, using:

# docker login

I get the following error message:

error getting credentials - err: exit status 1, out: `GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.secrets was not provided by any .service files`

I did not get any error messages, when I created my image on the remote server. [...]

A: As this is the currently selected answer, I think people should try @Anish Varghese solution below first as it seems to be the easiest. You only need to install the gnupg2 and pass packages:

# sudo apt install gnupg2 pass

If it doesn't work, then you can try my original solution here: [...]
2018  forumthread  stackexchange  issue  workaround  security  ubuntu  ubuntu.xenial  dbus  freedesktop  sysadmin  packages  example  cli  tips  2019 
december 2019 by ezequiel
How to Start Docker Containers Automatically - codeburst
When running Docker containers in production ensuring high availability can be challenge. Unlike VMs which run untouched for months or even years, containers are meant to be used for a very short lifespan — typically a few hours or a few days at most. With this constant church, you need a way to ensure that containers that are outdated, vulnerable, or malfunctioning are retired and replaced with new containers. But doing this manually is not scalable, and is prone to human error. The better way is to automate container creation and restarts. There are a few ways you can do this. Before you dive in, take a look at this wiki page with quite a few resources on how to start Docker containers.
docker  blogpost  2018  configuration  booting  sysadmin  tips  example  links  automation  systemd  linux 
december 2019 by ezequiel
How to make your own free VPN with Amazon Web Services
Internet users are spoiled for choice when it comes to VPN services, but they either require a monthly subscription, aren’t secure, or are just plain slow. Thankfully, alternatives do exist. They require a bit more technical know-how, but if you want something done right, you have to do it yourself.
amazon  amazon.aws  vpn  howto  tips  article  2018  blogpost  example  linux  amazon.linux  2019  windows  firewall  networking  privacy  terminal  ssh  proxy  sysadmin  cloudcomputing  free 
december 2019 by ezequiel
How To Disable Guest Account In Ubuntu - It's FOSS
Ubuntu and Linux Mint come with a default guest user account that does not require a password. In this tutorial, we shall see how to disable guest account in Ubuntu 16.04 and 14.04.
(me: the cli tool wasn't available for me; config file changes did work (put them in a new file in /etc/lightdm/lightdm.conf.d))
ubuntu.xenial  ubuntu.trusty  ubuntu  blogpost  linux  desktop  xfce  security  configuration  sysadmin  example  howto  xorg  gnome  cli  2018 
december 2019 by ezequiel
linker - Where is __dso_handle defined? - Stack Overflow
Q: I have an unresolved symbol error when trying to compile my program which complains that it cannot find __dso_handle. Which library is this function usually defined in? [...]
2016  2018  gcc  linking  linux  gnu  cli  development  tool  compiler  compatibility  internals  sharedlibraries  c  c++  stackexchange  forumthread 
november 2019 by ezequiel
Lionel Messi ● 13 Most Difficult Goals Ever Scored in Football ||HD|| - YouTube
Messi Impossible Goals in Football || Lionel Messi Hardest & Most Technically Difficult Goals Ever ||
messi  fcbarcelona  argentina  football  sports  video  youtube  english  2018  worldcup.2014  worldcup.2018 
october 2019 by ezequiel
Errors management [tcl-lang.org]
08-Feb-2010 - Error treatment in programming always seems to be an underestimated topic, often untold by and to newbies, while it's a useful thing that might be naturally taught along with the basics in a programming language. Only after some two years of studying Tcl/Tk I was able to find some information about this subject and develop myself a very basic and limited idea of how applications can avoid being crashed by bugs or misuse, so I would like to discuss some error management techniques with the experienced folks, while building up a tutorial from this discussion (something highly useful by aspiring Tclers like me). And, please, treat the errors you find...
tcl  programming  tips  howto  forumthread  example  links  2010  2018 
october 2019 by ezequiel
Performance: C++ vs Rust - Knoldus Blogs
Rust doesn’t have any special feature which makes it FAST and different from C and/or C++, while it is much safer than C++ because of protection mechanisms it follows which in principle, are also doable in C++, using unique_ptr and shared_ptr and to achieve the same kind of safety that Rust has, we have to do so explicitly and set down standards and force patterns that increase the development effort. With Rust, the major part which makes it safer is that coding mistakes don’t create runtime errors — it creates compilation errors.
rust  c++  performance  comparison  development  blogpost  2018  security 
october 2019 by ezequiel
What is LLVM? The power behind Swift, Rust, Clang, and more | InfoWorld
Learn how the compiler framework for programmatically generating machine-native code has made it easier than ever to roll new languages and enhance existing ones.
llvm  article  2018  compiler  design 
october 2019 by ezequiel
Kobo Aura H20 - Screen Issues - RedFlagDeals.com Forums
A: I had that issue with the earlier Aura HD. Same experience with Kobo customer service. So I pried the case open and discovered that its operating system is contained on an internal microSD card that normally sits in a slot held in place by friction only, and it had come loose. I guess I must have dropped it at the wrong angle at some point, and the card just popped out. Initially it was just loose, and gave me erratic freezing for a few days, then it came out completely and everything froze permanently. I pushed it back in place and everything was fine again.
The difficult part is going to be prying open the H2O case so that it doesn't get marked up and lose its waterproofing.
2018  forumthread  kobo.reader  hardware  issue  memory  howto  guide 
october 2019 by ezequiel
Installation of IceWM on Ubuntu 16.04 · Issue #222 · bbidulock/icewm
(me: includes link to a github repository [https://github.com/Code7R/icewm] containing chnages to build debianpkg (debian packages))
ubuntu  ubuntu.xenial  2018  install  build  howto  links  example  github  forumthread  issue  icewm  debianpkg 
october 2019 by ezequiel
fonts - Firefox freezing with 100% CPU usage for 30 seconds when launching Chromium - Ask Ubuntu
Q: Recently I started to observe this very confusing and annoying, not to say worrying behaviour when having Firefox open and then launching Chromium:
For around 30 seconds, Firefox' child processes would consume all available CPU resources, causing websites to stop render (already displayed page freezes, new pages show a white page with grey spinning circle) while the overall window is still responsive (menus, page scrolling, switching tabs, even internal pages like about:config or about:preferences work...). Chromium itself does not show any symptoms. Terminating Chromium again immediately, while Firefox is spinning, does not stop the behaviour any faster. [...]
2018  firefox  chromium  fonts  issue  workaround  performance  linux  ubuntu  gtk  links  ubuntu.bionic  packages  stackexchange  forumthread  tips 
september 2019 by ezequiel
1495900 - starting Chrome makes Firefox content processes hang for about two minutes, due to FontConfig font rescanning (FcInitReinitialize)
Q: Sometime in the past few weeks I've noticed a regression: when I start Chromium (Ubuntu's packaged version of it) to test something, all of my Firefox content processes hang for about 2 minutes. [...]
Looks like this is not only within fontconfig, it's within fontconfig called from GTK code. That seems like it may not really be under our control. I guess what's happening is that when chromium is started, it's changing the (global) fontconfig configuration in such a way that fontconfig (in any process that uses it) decides it needs to reinitialize everything. [...]
2018  firefox  chromium  fonts  issue  workaround  performance  crash  linux  ubuntu  gtk  links  ubuntu.bionic  packages 
september 2019 by ezequiel
linux - "Cannot allocate memory" despite free reporting "available" - Stack Overflow
Q: I got this error from qemu, trying to start a VM with 3GB memory:

ioctl(KVM_CREATE_VM) failed: 12 Cannot allocate memory
failed to initialize KVM: Cannot allocate memory
[...]

A: [...] echo 1 > /proc/sys/vm/compact_memory [...]
qemu  issue  memory  workaround  virtualisation  links  forumthread  stackexchange  2017  2018  kernel  example  cli  sysadmin  linux 
august 2019 by ezequiel
[SOLVED] Not all games showing up in OPL via SMB? - PS2-HOME.com - PS2 Homebrew and Tools
Q: [...] I have gotten SMB to work pretty well, I put in more games today but only half of them will show up.

Reconnecting does not solve the problem, is there a limit to the amount of games SMB can show?
2018  opl.ps2  vg.plat.ps2  howto  tips  example  gaming  issue  workaround  fix  forumthread  tutorial  samba  configuration  links  faq  windows  cd  dvd  info  freemcboot  backup  compatibility 
august 2019 by ezequiel
Mastering ESR backup DVDs from CD-ROM games? : ps2
Q: [...] While the last two steps work well for DVD games, the process fails for CD games, as FreeMcBoot's ESRloader fails to read the disc. Is there anything I'm missing in the process of converting the BIN/CUE to a UDF-compatible ISO?
2018  reddit  forumthread  backup  iso  fileformats  cli  linux  unix  howto  tips  example  converter  vg.plat.ps2 
july 2019 by ezequiel
PS2 - ESR | PSX-Place
ESR beta r9b coded by ffgriever.
Download in attachment below. [...]
forumthread  releaserelated  freemcboot  vg.plat.ps2  hacking  2018  links  gui  dvd  backup  download  downloads 
july 2019 by ezequiel
PS2 - ESR GUI | PSX-Place
It's based on ESR r9b (not yet published, I didn't have time to make proper testing, so most likely it will be released tommorow). [...]
freemcboot  opl.ps2  gui  vg.plat.ps2  software  dvd  cd  booting  hacking  backup  download  2018 
july 2019 by ezequiel
These are the best password managers. Because reusing passwords is dangerous. - The Washington Post
Pardon the interruption, but your passwords are leaking.
You’ve probably become numb to all the headlines about data breaches. But a website called Have I Been Pwned will expose the horror they’ve wreaked on you. [...]
privacy  security  article  2018  web  browser  links 
june 2019 by ezequiel
Running Docker Containers with Systemd question - General Discussions / General - Docker Forums
Q: [...] I’m looking for information about how systemd interacts with Docker containers. I implemented systemd unit file for one of my container. [...]
2018  forumthread  docker  systemd  issue  example  sysadmin 
june 2019 by ezequiel
List of mobile browser User-Agent strings
[...] Here’s a handy list of UAs that you may want to use. [...]
browser  mobile  reference  2018  internet  chrome.browser  safari  opera  ie  web 
june 2019 by ezequiel
Docker Network not Found - Stack Overflow
Q: In our team, we are currently transitioning to Docker to deploy everything on our server.

We are using Docker Swarm and multiple (10+) compose files defining plenty (20+) of services. Everything works beautifully so far, except when we take down our stack using docker stack rm <name> (and redeploy using docker stack deploy <options> <name>): about every second time, we get the following error:

Failed to remove network <id>: Error response from daemon: network <id> not foundFailed to remove some resources from stack: <name>

When using docker network ls, the network is indeed not removed, however, docker network rm <id> always results in the following:
[...]
2018  forumthread  stackexchange  networking  deployment  issue  links  workaround  linux  docker 
june 2019 by ezequiel
Docker compose can not start. Service network not found after restart docker · Issue #2194 · docker/for-win
[...]
Expected behavior
On restart the containers must start automatically without errors.

Actual behavior
All the containers run ok after running the command docker-compose -up -d. The problem is when I restart the docker service. Then, once restarted, all the containers are stoped and when I run the command docker-compose start the following error is shown:

Error response from daemon: network ccccccccccccc not found
[...]
2018  issue  docker  github  networking  sysadmin 
june 2019 by ezequiel
ufw-docker/ufw-docker at master · chaifeng/ufw-docker
[...]
Usage:
ufw-docker <list|allow> [docker-instance-id-or-name [port[/tcp|/udp]]]
ufw-docker delete allow [docker-instance-id-or-name [port[/tcp|/udp]]]
ufw-docker service allow <swarm-service-id-or-name <port</tcp|/udp>>>
ufw-docker service delete allow <swarm-service-id-or-name>
ufw-docker <status|install|check|help>
Examples:
[...]
(me: script linked from https://github.com/chaifeng/ufw-docker)
2018  script  ufw  networking  linux  firewall  sysadmin  automation  ubuntu  iptables  docker  github 
june 2019 by ezequiel
How to Install and Use Ace Stream Easily in Ubuntu / Mint Linux
[...] But recently, I found out a snap was released for it, and now everything is much easier in newer versions of Ubuntu or Linux Mint. So I could install it in Ubuntu 16.04. [...]
linux  mint  blogpost  howto  guide  tips  cli  example  sysadmin  2018  acestream  player  software  install  installation  snap.app 
june 2019 by ezequiel
Autostart – How to run a service on Linux boot time using systemd – Better-Coding
We start defining a new service by creating my-service.service file located in /etc/systemd/system directory:

sudo nano /etc/systemd/system/my-service.service
The following listing presents the simplest configuration, which is required to run the service. As you can see it is very simple. We put only the name of the service and commands responsible for to starting and stopping our service.
docker  blogpost  2018  example  tips  linux  systemd 
june 2019 by ezequiel
Docker Cheat Sheet | Razorops
Developers can get going quickly by starting with one of the 13,000+ apps available on Docker Hub. Docker manages and tracks changes and dependencies, making it easier for sysadmins to understand how the apps that developers build work. And with Docker Hub, developers can automate their build pipeline and share artifacts with collaborators through public or private repositories.
docker  cheatsheet  2018  links  example  tips  sysadmin 
june 2019 by ezequiel
Top 10 Docker CLI commands you can’t live without – The Code Review – Medium
Docker is a great tool for building microservices, allowing you to create cloud-based applications and systems. To make the most of it via your terminal, here is a run down of the top 10 Docker commands for your terminal.
howto  example  tips  cli  sysadmin  docker  linux  unix  windows  macosx  blogpost  2018 
june 2019 by ezequiel
OSMC Vs. OpenELEC Vs. LibreELEC – Kodi Operating System Comparison - Jerry_Jin - 博客园
Kodi’s two slim-and-trim kid brothers LibreELEC and OpenELEC were once great solutions for getting the most out of limited hardware. But now that even the cheapest Kodi boxes are more than powerful enough to run the deluxe Kodi operating system known as OSMC, are LibreELEC and OpenELEC are becoming irrelevant?
osmc  libreelec  openelec  article  blogpost  comparison  2018  raspberrypi  xbmc  review  links  history  player  streaming  streamingaudio  tv  sports  os 
june 2019 by ezequiel
linux - Self signed certificate not trusted - Super User
A: [...] After solving this, httpie is behaving properly. It is strange that curl was not complaining about this.

This is not yet solving the problem in Chrome though ... I assume that Chrome does not use system-wide CAs.
stackexchange  forumthread  2018  ssl  tls  security  internet  software  chrome.browser  chromium  firefox  links  tips  cli  example  linux  unix  openssl 
may 2019 by ezequiel
SC2166 · koalaman/shellcheck Wiki
The XSI extensions specifying the -a and -o binary primaries and the '(' and ')' operators have been marked obsolescent. (Many expressions using them are ambiguously defined by the grammar depending on the specific expressions being evaluated.) Scripts using these expressions should be converted to the forms given below. [...]
shell  bash  standards  2018  posix  github  wikientry  scripting  cli 
may 2019 by ezequiel
auto-suspend can't be disabled when GDM is active (#22) · Issues · GNOME / gnome-control-center · GitLab
With GNOME 3.28, system automatically suspends after 20 minutes. That can be adjusted/disabled in system settings - however, it only applies to that particular user session. When GDM is the active screen, the system still suspends after 20 minutes, and there's no way to configure that. That affects e.g. the following use cases: [...]
gnome  gnome3  configuration  powermanagement  issue  workaround  forumthread  linux  xfce  fedora  2018  desktop 
may 2019 by ezequiel
Bicycle Cards - Site Index [bicyclecards.org]
This page lists all back designs. Every entry has an active link. [Pages that have been updated further or most recently are marked with the number in red.]
2018  info  playingcards  links 
april 2019 by ezequiel
x86 - Why is string comparison so fast in python? - Stack Overflow
Q: I became curious to understand the internals of how string comparison works in python when I was solving the following example algorithm problem: [...]
forumthread  stackexchange  python  performance  comparison  example  programming  2018  cpu  x86  amd64  tips  links  optimisation 
april 2019 by ezequiel
Primer on Python Decorators – Real Python
In this tutorial on decorators, we’ll look at what they are and how to create and use them. Decorators provide a simple syntax for calling higher-order functions.

By definition, a decorator is a function that takes another function and extends the behavior of the latter function without explicitly modifying it.
python  tutorial  howto  tips  example  online  2018  programming  article  2016  2015 
april 2019 by ezequiel
Midnight Commander Tips and Tricks
[...] Some novices complain that mc is just too idiosyncratic for them. Here is a pretty typical lament that the user jhfry wrote in his response to Slashdot story Midnight Commander Development Revived (January 26 2009) [...]
tips  faq  howto  links  2018  mc  linux  unix  cygwin  configuration  cli  textui  curses  macosx 
april 2019 by ezequiel
Documentation for DeDRM under Linux · Issue #702 · apprenticeharper/DeDRM_tools
I have followed this guide to try to unlock Adobe Digital Editions book under Linux.

I had figured out that installing Python and PyCrypto under wine, and under the same setup (which means, correctly, that I had to install it under the wine 32 prefix I used to install ADE) is not necessary. [...]
2018  drm  issue  workaround  links  github  tool  opensource  linux  configuration  wine  winecompatible  installation 
april 2019 by ezequiel
Calibre plugin on Linux fails to find python.exe · Issue #720 · apprenticeharper/DeDRM_tools
winetricks python26 by defaults installs python.exe to C:\python26\python.exe.

However, DeDRM runs it without path:

DeDRM v6.6.1: Command line: 'WINEPREFIX="/prefix/adobe-digital-editions-2.0"
wine python.exe "/home/user/.config/calibre/plugins/DeDRM/libraryfiles/adobekey.py" "/home/user/.config/calibre/plugins/DeDRM/libraryfiles/winekeysdir"'
...
wine: cannot find L"C:\\windows\\system32\\python.exe"

This should be easy to to fix, by setting WINEPATH to contain all usual directories where python.exe is installed. For example:

export WINEPATH='C:\python26;C:\windows\system32'
wine python.exe
[...]
drm  tool  issue  linux  winecompatible  wine  configuration  howto  tips  example  2018  workaround  adobe  opensource  github 
april 2019 by ezequiel
amazon web services - Is there a way to export an AWS CLI Profile to Environment Variables? - Stack Overflow
Q: When working with certain third-party tools like Terraform, it's not easily possible to specify an AWS CLI profile, and I like working with the environment variables better than the profiles.

Is there a way for me to have the AWS CLI simply export the current profile as AWS_ACCESS_KEY_ID and AWS_SECRET_KEY environment variables to my session?
cli  environment  shell  unix  linux  example  tips  amazon.aws  forumthread  stackexchange  2016  2018  script  terraform 
april 2019 by ezequiel
Top 100 Mysteries & Thrillers on Goodreads - Goodreads News & Interviews
Culprits, spies, bad guys, and women with vendettas: There's something so very satisfying about spending your time with the criminal element. And by that, we mean following the clues and solving the capers when you sit down with a great mystery or thriller. Always in search of a great book, Goodreads recently set out to uncover your 100 most-loved thrillers and mysteries.
2018  books  reviews  links  blogpost  english 
april 2019 by ezequiel
Mock - Mocking and Testing Library — Mock 1.0.1 documentation [voidspace.org] [archive.org]
mock is a library for testing in Python. It allows you to replace parts of your system under test with mock objects and make assertions about how they have been used.
mock is now part of the Python standard library, available as unittest.mock in Python 3.3 onwards.
mock provides a core Mock class removing the need to create a host of stubs throughout your test suite. After performing an action, you can make assertions about which methods / attributes were used and arguments they were called with. You can also specify return values and set needed attributes in the normal way.
development  python  test  unittest  framework  links  documentation  reference  guide  tutorial  online  archived.version  2012  2018 
march 2019 by ezequiel
Ensure Data Integrity of Objects in Amazon S3
Q: I want to upload an object to an Amazon Simple Storage Service (Amazon S3) bucket. Additionally, I want to verify the integrity of the uploaded object using the MD5 checksum value. How can I do that?
faq  howto  guide  amazon.aws  amazon.s3  cli  windows  linux  unix  macosx  example  2018  2016  info  links  tips 
february 2019 by ezequiel
Investigating GitLab [LWN.net]
Daniel Vetter began his talk in the refereed track of the 2018 Linux Plumbers Conference (LPC) by noting that it would be in a somewhat similar vein to other talks he has given, since it is about tooling and workflows that are outside of the kernel norm. But, unlike those other talks that concerned changes that had already taken place, this talk was about switching open-source graphics projects to using a hosted version of GitLab, which has not yet happened. [...]
article  2018  linux  kernel  gitlab  review  links  presentation  video  git  scm  casestudy 
february 2019 by ezequiel
Hacking the Kobo Clara HD – 5: Setting up SSH
Last time, we set up telnet on the Clara HD and set up the USB network interface. Now we will extend this to enable SSH on the device.
kobo.reader  kobo.reader.app  howto  install  guide  blogpost  links  2018  hardwaresupport  cli  example  ssh 
february 2019 by ezequiel
Burning CDI's on Linux : dreamcast
Q: Everyone is telling me it's impossible to burn a CDI to a CD and have it work, I've got Brasero installed and that should work. Does Brasero or any other graphical CD burning software work on Linux? [...]
2018  forumthread  reddit  cd  dvd  burning  tips  links  software  linux  iso  winecompatible  fileformats  howto  example 
february 2019 by ezequiel
FC Barcelona: Messi supera a Raúl y se acerca al récord de victorias en la historia de LaLiga | Marca.com
Con el triunfo cosechado por el Barcelona en el campo del Girona, Messi adelantó a Raúl en la clasificación de los jugadores que más victorias han conseguido en la historia de la competición.Leo alcanzó anoche los 328 triunfos ligueros en 437 encuentros, mientras que Raúl se marchó de LaLiga Santander con 327 victorias en 550 partidos disputados.
article  messi  football  spanish  2018  spain  sports 
january 2019 by ezequiel
Paulo Dybala: How the Argentine 'Gladiator' went from rough diamond to Juventus 'jewel' - BBC Sport
On the surface, Laguna Larga looks no different from any other small town in Argentina.
article  2018  argentina  english  football  sports  bbc 
january 2019 by ezequiel
« earlier      
per page:    204080120160

related tags

acestream  acpi  activism  adobe  amazon  amazon.aws  amazon.linux  amazon.s3  amd64  android  apple  arch  archived.version  argentina  article  audio  automation  backup  bash  battery  bbc  bios  bitcoin  blogpost  books  booting  browser  build  burning  business  c  c++  casestudy  cd  centos  cheatsheet  chrome.browser  chromium  cli  cloudcomputing  comedy  comparison  compatibility  compiler  concurrency  configuration  converter  copyright  corporate  cpu  crash  crypto.blockchain  crypto.hashgraph  cryptocurrency  curses  cygwin  dbus  debian  debianpkg  debug  deployment  design  desktop  development  dhcp  dns  dnsmasq  docker  documentary  documentation  download  downloads  drm  dvd  electronics  emailmessage  emulation  emulator  england  english  enlightenment  environment  europe  ev.contrib  example  exploit  facebook  faq  fcbarcelona  fedora  fileformats  filemanager  finances  firefox  firewall  fix  fonts  food  football  forumthread  framework  free  freedesktop  freedom  freemcboot  funny  gaming  gcc  git  github  gitlab  gnome  gnome3  gnu  golang  grub  gtk  gui  guide  hacking  haproxy  hardware  hardwaresupport  health  history  howto  icewm  ie  info  install  installation  internals  internet  interview  iptables  iso  issue  jtag  kernel  kernelmodule  kernelpatches  keyboard  kobo.reader  kobo.reader.app  laptop  law  libreelec  linking  links  linux  llvm  lxde  mac  macosx  maradona  mc  memory  messi  mint  mobile  money  music  neovim  networking  news  online  openelec  opensource  openssl  openwrt  opera  opl.ps2  optimisation  os  osmc  packages  pam  parenting  patches  performance  player  playingcards  plugin  politics  posix  powermanagement  ppa  presentation  privacy  programming  proxy  python  qemu  raspberrypi  raspbian  reader  reddit  redhat  reference  releaserelated  remote  review  reviews  router  rust  safari  samba  scm  screenshots  script  scripting  security  serverapp  sharedlibraries  shell  snap.app  software  spain  spanish  spec  sports  squid  ssh  ssl  stackexchange  standards  streaming  streamingaudio  sudo  support  sysadmin  systemd  tcl  terminal  terraform  test  textprocessing  textui  tips  tls  tool  tools  train  travel  tutorial  tv  ubuntu  ubuntu.bionic  ubuntu.cosmic  ubuntu.trusty  ubuntu.xenial  udev  ufw  ui  uk  unittest  unix  usa  usb  vg.plat.ps1  vg.plat.ps2  video  vim  virtualisation  vpn  wales  wayland  web  webapp  wifi  wikientry  windowmanager  windows  wine  winecompatible  workaround  worldcup  worldcup.1986  worldcup.2014  worldcup.2018  x11  x86  xbmc  xfce  xorg  yaml  youtube 

Copy this bookmark:



description:


tags: