racl101 + issue   59

docker - Dockerized nginx is not starting - Stack Overflow
Docker container runs as long as the command you specify with CMD, ENTRTYPOINT or through the command line is running. In your case the service command finishes right away and the whole container is shut down.

One way to fix this is to start nginx directly from the command line (make sure you don't run it as a daemon).
stackoverflow  howto  troubleshoot  nginx  image  container  server  not  starting  fix  issue  daemon  CMD  ENTRYPOINT  configuration  command  example  guide  reference 
december 2018 by racl101
Failed to download Chromium r515411 · Issue #1597 · GoogleChrome/puppeteer
In short: when installing Puppeteer and you get an error about downloading chromium, you might get an error. It could be an intermittent connection so try a few more times to see if works.
github  forum  puppeteer  google  chrome  chromium  headless  browser  issue  howto  troubleshoot  fix  example  guide  reference 
november 2018 by racl101
Connecting to a mysql running on a Docker container · Issue #95 · docker-library/mysql
Frankly, this forum page has no consensus on a solution to this issue. Nevertheless, what worked for me on my set up with running MacOS as the Docker host and running a container with: Ubuntu 16.04 and MySQL 5.7 is the following:

1) Within the container: change in /etc/mysql/mysql.conf.d/mysqld.cnf the bind-address option from 127.0.0.1 to 0.0.0.0
2) Restart MySQL server (note that whenever you start MySQL you must use this command in the Dockerfile:

RUN sed -i -e"s/^bind-address\s*=\s*127.0.0.1/bind-address = 0.0.0.0/" /etc/mysql/mysql.conf.d/mysqld.cnf
RUN find /var/lib/mysql -type f -exec touch {} \; && service mysql start

That is, you must touch the files in /var/lib/mysql and then start the server with service command and not systemctl.

Next, create a user separate from root e.g. dev_1, in MySQL and given them privileges to their '0.0.0.0' and '%' hosts. Like this in the Dockerfile:

RUN find /var/lib/mysql -type f -exec touch {} \; && service mysql start && mysql -uroot -proot mysql -e "GRANT ALL ON *.* TO root@'0.0.0.0' IDENTIFIED BY 'secret' WITH GRANT OPTION; CREATE USER 'dev_1'@'0.0.0.0' IDENTIFIED BY 'secret'; GRANT ALL ON *.* TO 'dev_1'@'0.0.0.0' IDENTIFIED BY 'secret' WITH GRANT OPTION; GRANT ALL ON *.* TO 'dev_1'@'%' IDENTIFIED BY 'secret' WITH GRANT OPTION; FLUSH PRIVILEGES;"

Then when you start the container you must publish the port number like so:

docker run -t -d -p 4406:3306 ubuntu_16_04_lemp_php_7_2:latest

If your container stops prematurely, then you might want to add a CMD line in your docker file to run a start.sh script and within that script you might want to add something like this:

# stupid hack to keep container from being stopped
tail -f /dev/null

Finally, to connect to your DB instance on your local MacOS machine with an app like Sequel Pro for example, use the following credentials:

Host: 0.0.0.0
Username: dev_1
Password: <dev_1_password>
Port: 4406

If you don't like to use port 4406, try 3307, 3308, 3309.
github  forum  howto  example  troubleshoot  mysql  server  docker  host  connection  issue  sequel  pro  mariadb  client  hostname  docker-machine  ip  address  ipaddress  guide  reference  toread  tolearn  totry  tounderstand  image  port  detached  database  credentials 
october 2018 by racl101
ajv@^6.0.0 is missing · Issue #9691 · angular/angular-cli
I fixed this for myself by installing: npm install ajv@^6.0.0 from within the project directory. Not sure if this is the best way of dealing with the issue.
github  forum  angular  angular-cli  npm  install  howto  troubleshoot  issue  error  ajv  dependency  project  guide  reference 
april 2018 by racl101
PHP 5.6 error on vagrant provision · Issue #625 · laravel/homestead
vagrant destroy && rm -rf .vagrant && vagrant up

This is actually a missing step from Laravel's Homestead, updating vagrant box documentation. Know that it will delete all your databases so back them up.
github  forum  laravel  homestead  issue  php-fpm  service  provision  vagrant  box  destroy  howto  troubleshoot  guide  reference 
february 2018 by racl101
[5.4] SQL error when migrating tables · Issue #17508 · laravel/framework
Shows how to troubleshoot issue with Laravel 5.4 which the utf8mb4 character set by default but causes issues with older versions of MySQL.
github  laravel  laravel5  laravel5.4  issue  character  set  encoding  database  mysql  mysql5  howto  fix  troubleshoot  forum 
april 2017 by racl101
Bundler fails on mysql2 gem (OS X) · Issue #695 · cantino/huginn
Do this when deploying with Capistrano and mysql is required as a gem.
Tool  commandline  Xcode-select  macox  Howto  Forum  Fix  macosx  Brew  macos  Mysql2  Issue  Github  gem  Homebrew  Bundler 
march 2017 by racl101
ruby 2.2.0 rails 4.0.13 and rspec 3.1.0 cannot load such file -- test/unit/assertions · Issue #1273 · rspec/rspec-rails
Solved my issue when trying to set up Rspec tests using: Ruby 2.2.0, Ruby on Rails 4.2.0. Turns out I was missing the gem: 'test-unit' in my test group inside the Gemfile.
rspec  Github  Forum  troubleshoot  Fix  Howto  unit  testing  Issue  unittest 
november 2016 by racl101
php - Automatically clearing tmp files in webgrind - Stack Overflow
Helped me fix issue where I was running out of space on my Macbook because xdebug created huge cachegrindfiles in my /private/var/tmp/ directory that I couldn't find.
fix  Stackoverflow  profiler  xdebug  Howto  example  cachegrind  Space  disk  issue 
march 2015 by racl101
[SOLVED] [Laravel 5] Where is the models folder? - Laravel.IO - The Official Laravel PHP Framework Community Portal
You can have models anywhere you want them. The built in User model is placed directory under app/. If you want to use a specific folder for all your models, create on inside app/ named Models and then namespace all your models with App\Models\X.
Laravel  Laravel5  models  directory  issue  fix  example  Howto  forum 
march 2015 by racl101
Wordpress keeps redirecting to install-php after migration - Stack Overflow
Solution for problem where you keep getting redirected to install.php script on WordPress.
WordPress  install  example  latest  Howto  version  stackoverflow  issue  redirect  Wpengine  troubleshoot 
november 2014 by racl101

related tags

$  acf  address  advanced-custom-fields  ajv  amazon  angular  angular-cli  Angularjs  ansible  APi  Apple  appleId  application  app_cipher  app_key  apt-get  architecture  askubuntu  auto  autoload  aws  bestpractices  blade  block  blog  box  branch  Brew  browser  browsers  bug  build  builder  Bundler  cachegrind  calendar  caveat  cgi.fix_pathinfo  character  chrome  chromium  class  classname  client  cloud  CMD  codeigniter  column  command  commandline  comments  compilation  compile  completion  component  compose  composer  composer.json  composer.lock  config  configuration  conflict  connection  container  cookies  credentials  csrf  csv  daemon  data  database  db  declaration  default  dependency  deploy  deployment  destroy  detached  directive  directory  disk  docker  docker-compose  docker-machine  doctor  domain  dump  duplicate  editor  encoding  ENTRYPOINT  environment  envoy  error  escape  escaping  events  example  explanation  export  expressionengine  extension  external  FAker  fastcgi  field  file  files  filesystem  fix  folder  font  fonts  force  forum  found  framework  fully  gem  git  github  google  gotcha  gravityforms  Groups  guide  hack  headless  Homebrew  homestead  host  hostname  howto  hsts  https  icloud  ie  image  images  import  ini  install  interpolation  interpreter  intl  invalid  invoiceninja  ios  iOS8  ip  ipaddress  issue  iterm  iterm2  java  javascript  jenkins  jquery  json  laracasts  laravel  laravel4  laravel5  laravel5.4  laravel5.5  latest  library  loading  location  login  lumen  lumen5.1  macos  macosx  macox  many  mariadb  menu  meslo  message  method  mime  mix  model  models  module  multitenancy  multitenant  mysql  Mysql2  mysql5  named  nav  navigation  nginx  no  not  npm  ohmyzsh  open  optionals  order  Package  page  pagodabox  passport  path  php  php-fpm  php.ini  pip  playbook  plugin  port  postgres  postgresql  pro  problem  production  profiler  project  provider  provision  puppeteer  purge  python  python2.7  qualified  Rails  recognition  reconnect  redirect  redis  reference  region  relative  remove  revision  role  roots  routes  routing  rspec  Ruby  rubyonrails  runtime  safari  saving  Script  sdk  secret  section  seeder  sequel  server  service  session  set  setting  settings  shell  single  spa  Space  sqlalchemy  ssl  stackexchange  stackoverflow  standalone  start  starting  storage  string  support  svg  swift  symbols  Syntax  Tag  template  testing  text  theme  tld  token  tokenmismatchexception  tolearn  too  tool  toread  totry  tounderstand  troubleshoot  troubleshooting  troubleshot  try_files  tutorial  type  ubuntu  ubuntu16.04  unit  unittest  Unverified  unzip  upgrade  vagrant  variables  version  volumes  vue  vue2  vuejs  warning  webkit  without  wordpress  workaround  Wpengine  Xcode-select  xcode8  xcode9  xdebug  youtube  zip  zsh 

Copy this bookmark:



description:


tags: